IoTDB 存在远程代码执行漏洞

来源: 投稿
2024-01-17 10:54:00

漏洞描述

Apache IoTDB是时序数据的数据管理系统,为用户提供数据采集、存储、分析等特定服务。JEXL是一个表达式语言引擎,全称是Java表达式语言(Java Expression Language),可以在 java 程序中动态地运算一些表达式

在受影响版本中,由于IoTDB通过UDTFJexl.java实现 JEXL 表达式支持。攻击者可以通过配置 UDF,调用 JEXL表达式来执行 JAVA命令,导致存在远程代码执行漏洞。

漏洞名称 IoTDB 存在远程代码执行漏洞
漏洞类型 表达式语言注入
发现时间 2024-01-15
漏洞影响广度 一般
MPS编号 MPS-c4ml-t1ka
CVE编号 CVE-2023-46226
CNVD编号 -

影响范围

iotdb@[1.0.0, 1.3.0)

org.apache.iotdb:iotdb-core@[1.0.0, 1.3.0)

修复方案

将 org.apache.iotdb:iotdb-server 升级至 1.3.0 及以上版本

将组件 iotdb 升级至 1.3.0 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-c4ml-t1ka、 证明影响版本

证明影响版本

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部