Atlassian Confluence 模板注入代码执行漏洞

来源: 投稿
2024-01-16 18:33:00

漏洞描述

Confluence 是由Atlassian公司开发的企业协作和文档管理工具。

Atlassian Confluence Data Center/Server 受影响版本中存在模版注入漏洞,攻击者通过构造恶意请求,可以在未登录的情况下在Confluence实例上触发远程代码执行漏洞。

漏洞已在8.5.4版本中修复,可能与velocity引擎中对snakeyaml、antlr等组件的支持有关

漏洞名称 Atlassian Confluence 模板注入代码执行漏洞
漏洞类型 表达式语言注入
发现时间 2024-01-16
漏洞影响广度 一般
MPS编号 MPS-2023-0028
CVE编号 CVE-2023-22527
CNVD编号 -

影响范围

confluence_data_center@[8.0.0, 8.5.4)

confluence_server@[8.0.0, 8.5.4)

修复方案

将 confluence_data_center 升级至 8.5.4 及以上版本

将confluence_data_center升级至 8.6.0 及以上版本

将confluence_data_center升级至 8.7.1 及以上版本

将 confluence_server 升级至 8.5.4 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-2023-0028

证明影响版本

证明影响版本

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部