Apache Solr 环境变量信息泄漏漏洞

来源: 投稿
2024-01-15 10:50:00

漏洞描述

Apache Solr 是一款开源的搜索引擎。

在 Apache Solr 受影响版本中,由于 Solr Metrics API 默认输出所有未单独配置保护策略的环境变量。在默认无认证或具有 metrics-read 权限的情况下,攻击者可以通过向 /solr/admin/metrics 端点发送恶意请求,从而获取到运行 Solr 实例的主机上的所有系统环境变量,包括敏感信息的配置、密钥等。

漏洞名称 Apache Solr 环境变量信息泄漏漏洞
漏洞类型 未授权敏感信息泄露
发现时间 2024-01-13
漏洞影响广度 广
MPS编号 MPS-xjy6-0kiu
CVE编号 CVE-2023-50290
CNVD编号 -

影响范围

org.apache.solr:solr-core@[9.0.0, 9.3.0)

solr@[9.0.0, 9.3.0)

修复方案

将 org.apache.solr:solr-core 升级至 9.3.0 及以上版本

将组件 solr 升级至 9.3.0 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-xjy6-0kiu

 

 

 

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部