Apache Cassandra 存在越权漏洞导致远程命令执行

来源: 投稿
2023-05-31 11:20:00

漏洞描述

Apache Cassandra 是 Apache 基金会的一个分布式 Nosql 数据库。

Apache Cassandra 的受影响版本中,由于没有对JMX/nodetool权限的用户做限制,当启动FQL/Audit日志时,拥有 JMX/nodetool 权限的攻击者可以以 cassandra 的身份权限执行任意系统命令。

用户可以通过将 FQL/Auditlog 配置属性 allow_nodetool_archive_command 设置为 false 来缓解该漏洞。

漏洞名称 Apache Cassandra 存在越权漏洞导致远程命令执行
漏洞类型 特权管理不恰当
发现时间 2023-05-30
漏洞影响广度
MPS编号 MPS-kaz2-jmpq
CVE编号 CVE-2023-30601
CNVD编号 -

影响范围

org.apache.cassandra:cassandra-all@[4.1.0, 4.1.2)

org.apache.cassandra:cassandra-all@[4.0.0, 4.0.10)

修复方案

将组件org.apache.cassandra:cassandra-all到4.0.10或更高版本

将组件org.apache.cassandra:cassandra-all到4.1.2或更高版本

将 FQL/Auditlog 配置属性 allow_nodetool_archive_command 设置为 false。

参考链接

https://www.oscs1024.com/hd/MPS-kaz2-jmpq

https://nvd.nist.gov/vuln/detail/CVE-2023-30601

Commit

    

免费情报订阅&代码安全检测

OSCS是国内首个开源软件供应链安全社区,社区联合开发者帮助全球顶级开源项目解决安全问题,并提供实时的安全漏洞情报,同时提供专业的代码安全检测工具为开发者免费使用。社区开发者可以通过配置飞书、钉钉、企业微信机器人获取一手的情报。

免费代码安全检测工具: https://www.murphysec.com/?src=osc

免费情报订阅: https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见: https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部