Apache Airflow Hive Provider <5.0.0 存在命令注入漏洞

来源: 投稿
2022-12-21 11:51:00

漏洞描述

Apache Airflow 是一个用于以编程方式创作、安排和监控工作流平台。Apache Airflow Hive Provider 是一个使用 SQL 读取、写入和管理分布式存储中的大型数据集的工具包。

Apache Airflow Hive Provider 在 5.0.0 之前的版本中由于对airflow/providers/apache/hive/hooks/hive.py文件中hive_cli_params参数不正确初始化,导致存在命令注入漏洞,攻击者通过控制hive_cli_params参数可利用该漏洞执行任意命令。

漏洞名称 Apache Airflow Hive Provider <5.0.0 存在命令注入漏洞
漏洞类型 命令注入
发现时间 2022-12-21
漏洞影响广度
MPS编号 MPS-2022-66662
CVE编号 CVE-2022-46421
CNVD编号 -

影响范围

apache-airflow-providers-apache-hive@[0, 5.0.0)

修复方案

将组件 apache-airflow-providers-apache-hive 升级至 5.0.0 及以上版本

参考链接

https://www.oscs1024.com/hd/MPS-2022-66662

Commit

CVE

    

情报订阅

OSCS(开源软件供应链安全社区)通过最快、最全的方式,发布开源项目最新的安全风险动态,包括开源组件安全漏洞、事件等信息。同时提供漏洞、投毒情报的免费订阅服务,社区用户可通过配置飞书、钉钉、企业微信机器人,及时获得一手情报信息推送:

https://www.oscs1024.com/cm/?src=osc

具体订阅方式详见:

https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
点击引领话题📣 发布并加入讨论🔥
0 评论
0 收藏
分享
返回顶部
顶部