PHP 存在输入验证不当漏洞

来源: 投稿
2022-09-29 18:20:00

漏洞描述

PHP 是一种开源的通用计算机脚本语言,尤其适用于网络开发并可嵌入HTML中使用。

PHP 的受影响版本中存在输入验证不当漏洞,攻击者可以利用此漏洞通过网络在受害者的浏览器中设置恶意 Cookie,该 Cookie 会被 PHP 应用程序视为一个 __Host-__Secure-格式的 cookie ,从而欺骗应用程序执行恶意操作。

漏洞名称 PHP 存在输入验证不当漏洞
漏洞类型 输入验证不恰当
发现时间 2022/9/29
漏洞影响广度 广
MPS编号 MPS-2022-12658
CVE编号 CVE-2022-31629
CNVD编号 -

影响范围

php@[8.1.0, 8.1.11)

php@(-∞, 7.4.31)

php@[8.0.0, 8.0.24)

修复方案

升级php到 7.4.31、8.0.24、8.1.11 或更高版本

参考链接

https://www.oscs1024.com/hd/MPS-2022-12658

https://nvd.nist.gov/vuln/detail/CVE-2022-31629

https://bugs.php.net/bug.php?id=81727

    

情报订阅

OSCS(开源软件供应链安全社区)通过最快、最全的方式,发布开源项目最新的安全风险动态,包括开源组件安全漏洞、事件等信息。同时提供漏洞、投毒情报的免费订阅服务,社区用户可通过配置飞书、钉钉、企业微信机器人,及时获得一手情报信息推送:

https://www.oscs1024.com/?src=osc

具体订阅方式详见:

https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
4 收藏
分享
2 评论
4 收藏
分享
返回顶部
顶部