vim/vim <9.0.0598 缓冲区溢出漏洞

来源: 投稿
2022-09-28 15:37:00

漏洞描述

Vim 是老式 UNIX 编辑器 Vi的一个大大改进的版本。

vim/vim 在9.0.0598之前版本中的win_new_width函数中未对窗口长度变量width的值进行限制,当窗口长度为负值时会造成缓冲区溢出漏洞,攻击者可利用此漏洞造成拒绝服务或执行恶意代码。

漏洞名称 vim/vim <9.0.0598 缓冲区溢出漏洞
漏洞类型 栈缓冲区溢出
发现时间 2022/9/28
漏洞影响广度 一般
MPS编号 MPS-2022-58108
CVE编号 CVE-2022-3324
CNVD编号 -

影响范围

vim/vim@(-∞, 9.0.0598)

修复方案

升级vim/vim到 9.0.0598 或更高版本

参考链接

https://www.oscs1024.com/hd/MPS-2022-58108

https://nvd.nist.gov/vuln/detail/CVE-2022-3324

https://github.com/vim/vim/commit/8279af514ca7e5fd3c31cf13b0864163d1a0bfeb

https://github.com/vim/vim

    

情报订阅

OSCS(开源软件供应链安全社区)通过最快、最全的方式,发布开源项目最新的安全风险动态,包括开源组件安全漏洞、事件等信息。同时提供漏洞、投毒情报的免费订阅服务,社区用户可通过配置飞书、钉钉、企业微信机器人,及时获得一手情报信息推送:

https://www.oscs1024.com/?src=osc

具体订阅方式详见:

https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
0 收藏
分享
3 评论
0 收藏
分享
返回顶部
顶部