Linux Kernel 释放后重用漏洞(Dirtycred POC 已公开)

来源: 投稿
2022-09-22 18:52:00

漏洞描述

Linux kernel是美国Linux基金会的开源操作系统Linux所使用的内核。

在Linux 内核的 net/sched/cls_route.c 实现的 route4_change 中发现了一个漏洞,该漏洞源于释放后重用,本地攻击者利用该漏洞会导致系统崩溃,可能会造成本地特权升级问题。

该漏洞已存在 POC。

漏洞名称 Linux kernel 释放后重用漏洞
漏洞类型 UAF
发现时间 2022/9/22
漏洞影响广度 一般
MPS编号 MPS-2022-52796
CVE编号 CVE-2022-2588
CNVD编号 -

影响范围

linux_kernel@[2.6.12-rc2, 5.19)

修复方案

升级Linux_Kernel到 5.19 或更高版本

参考链接

https://www.oscs1024.com/hd/MPS-2022-52796

https://nvd.nist.gov/vuln/detail/CVE-2022-2588

https://seclists.org/oss-sec/2022/q3/132

情报订阅

OSCS(开源软件供应链安全社区)通过最快、最全的方式,发布开源项目最新的安全风险动态,包括开源组件安全漏洞、事件等信息。同时提供漏洞、投毒情报的免费订阅服务,社区用户可通过配置飞书、钉钉、企业微信机器人,及时获得一手情报信息推送:

https://www.oscs1024.com/?src=osc

具体订阅方式详见:

https://www.oscs1024.com/docs/vuln-warning/intro/?src=osc

展开阅读全文
0 收藏
分享
0 评论
0 收藏
分享
返回顶部
顶部