Apache Tomcat 再爆严重安全漏洞

来源: 投稿
作者: 鉴客
2011-08-30

Apache Tomcat 再次爆出安全漏洞: 

漏洞:CVE-2011-3190  Apache Tomcat 绕过验证和信息泄露 
严重性:严重 
公布方:Apache软件基金会 
受影响的版本: 

  • Tomcat 7.0.0 ~ 7.0.20的所有版本
  • Tomcat 6.0.0 ~ 6.0.33的所有版本
  • Tomcat 5.5.0 ~ 5.5.33的所有版本
  • 早期的已不再提供支持的版本也可能受影响
    Apache Tomcat支持AJP协议,用来通过反向代理到Tomcat的请求和相关的数据,AJP协议的作用是,当一个请求包含请求主体时,一个未经允许的、包含请求主体首部分(或可能所有的)的AJP消息被发送到Tomcat。在某些情况下,Tomcat会把这个消息当作一个新的请求来处理,而不会当作请求主体。这可能导致攻击者完全控制AJP消息,允许攻击者:  

  • 插入已验证用户的名字
  • 插入任何客户端的IP地址(可能绕过任何客户端IP地址的过滤)
  • 导致用户之间的响应混乱
下面的AJP连接器实现 不会受到影响 

  • org.apache.jk.server.JkCoyoteHandler (5.5.x - default, 6.0.x - default)
下面的AJP连接器实现 会受到影响 

  • org.apache.coyote.ajp.AjpProtocol (6.0.x, 7.0.x - default)
  • org.apache.coyote.ajp.AjpNioProtocol (7.0.x)
  • org.apache.coyote.ajp.AjpAprProtocol (5.5.x, 6.0.x, 7.0.x)
此外,这个问题只适用于以下都为真的情况:  

  • POST请求被接受
  • 请求主体没有被处理
举例:参见   https://issues.apache.org/bugzilla/show_bug.cgi?id=51698  

解决措施:  

VIA   apache.org  

展开阅读全文
3 收藏
分享
加载中
更多评论
3 评论
3 收藏
分享
返回顶部
顶部