LiteFlowX-IDEA 插件全新发布啦!语法高亮,语法提醒,自动检测,智能跳转

来源: 投稿
2022-07-15 11:05:00

LiteFlow自从发布了2.8.0里程版之后,新的EL表达式的确在编排方面更加得心应手,但是美中不足的就是语法完全靠自己手打,一不小心拼错单词,检查半天。复杂语句少个括号,检查半天。

为此我们今天推出了LiteFlowX——IDEA版本的语法辅助插件。强大的辅助功能让使用者在编写EL表达式上规避掉这些问题。强大的辅助让你的下路稳如老狗!破三塔,冲高地!

LiteFlow是一个灵动的,高成长性的,社区驱动的,丝滑且正在变得越来越好用的国产开源规则引擎。

你如果对LiteFlow感兴趣的话,请移步官网进行了解:

官网:https://liteflow.yomahub.com/

Gitee托管仓库:https://gitee.com/dromara/liteFlow

Github托管仓库:https://github.com/dromara/liteflow

插件版本须知

  • LiteFlowX 插件版本自 v1.0.0 起,将不再支持 LiteFlow 2.7.X 及以下版本的特性。
  • 如果您使用的是旧版本的 LiteFlow 框架,请自行下载插件jar包安装。
  • 插件将来会致力于 LiteFlow 框架的最新版本特性做出更改和完善,使用本插件前请确保您使用的是最新的 LiteFlow 框架。

😋 支持项目

LiteFlowX 插件完全免费并开源,为了让各位小伙伴能使用到更优质的插件功能,可到仓库提issues哦!

如果插件觉得好用,请为这个插件打个五分好评!

如果插件源码对你开发有帮助,请为这个仓库点个星星!

Gitee仓库:

https://gitee.com/liupeiqiang/LiteFlowX

Github仓库:

https://github.com/Coder-XiaoYi/LiteFlowX

Jetbrains Marketplace:

https://plugins.jetbrains.com/plugin/19145-liteflowx

🍬 LiteFlowX 特性

  • 支持 LiteFlow 2.8.x 新的规则表达式语法(自动提示、语法高亮、语法检测)。
  • 特定的文件 Svg 图标,容易识别 LiteFlow 元素。
  • 能够识别Component、Chain。
  • Java 代码和 Chain的互相跳转。
  • Xml 文件与 LiteFlow 元素的互相跳转。
  • 提供LiteFLow工具箱,整个工程的Component、Chain,并且支持双击跳转。
  • 支持对 liteflow.ruleSource 属性的文件跳转。

🎉 安装LiteFlowX

按下组合键 Ctrl + Alt + S,打开 IDE settings 并选择 Plugins,在 Marketplace 搜索 LiteFlowX 并点击 install:

🌈 功能演示

1.智能提示Component和Chain

2.预检测Chain未命名或重复

3.自定义EL语法关键字颜色

4.支持Component和Chain跳转

5.支持局部变量

6.LiteFlow工具箱

各位小伙伴,赶紧去插件市场上去搜索安装吧!

展开阅读全文
点击加入讨论🔥(2) 发布并加入讨论🔥
2 评论
10 收藏
分享
返回顶部
顶部