smart-socket 1.6.0 发布,适配 JDK 11

来源: 投稿
2022-07-04 09:18:00

smart-socket 是一款极简、易用、高性能的国产开源 AIO 通信框架,旨在帮助开发人员轻松打造企业级通信应用。

这个版本犹豫了许久,没有别的新特性加入,仅仅是将JDK版本适配至 11,看似为了发版而发版。

为了避免对老用户造成困扰,先在此作一下澄清:1.5.x 系列的版本会依旧以 JDK 1.8 版本继续维护下去。

至于 1.6.0 决定升级至 JDK 11,也是无奈之举。关注 smart 系列作品的朋友应该清楚,我们目前维护的开源项目除了这款 AIO 通信框架,还有 smart-http、smart-servet,以及现阶段重点投入的 smart-mqtt。

对于smart-mqtt,我们规划通过 GraalVM 将 Java 应用编译成原生镜像,使其更好的部署于边缘场景。该设想存在较多的技术难题需要攻克,而当下面临的问题便是新版 GraalVM 已不再支持 JDK 1.8。Java 1.8 与 11 存在某些 API 的不兼容,会导致镜像编译失败,所以需要先对 smart-socket 进行 JDK 的适配升级。况且,如今业界很多项目已逐渐放弃 Java 8,或许我们应该尝试拥抱高版本JDK。 

此版本主要变化

  1. 适配 JDK 11,不再兼容 Java 8。

  2. 合并用户提交的PR,修复错误注释。

  3. 升级 SSL 插件以支持更高级别、更安全的加密通信(已同步更新至v1.5.19版本)。

maven 坐标

<dependency>
    <groupId>org.smartboot.socket</groupId>
    <artifactId>aio-core</artifactId>
    <version>1.6.0</version>
</dependency>

想要进一步了解 smart-socket,请移步以下链接不迷路:

 

展开阅读全文
精彩评论
编译版本用11,照样可以运行在JDK17上。之前是用8编译的不能正常运行在11的环境下。
2022-07-04 12:17
1
举报
直接一步到位,到17啊
2022-07-04 11:43
1
举报
该升级17
2022-07-04 10:51
1
举报
不如直接支持到jdk17
2022-07-04 10:35
1
举报
4 收藏
分享
7 评论
4 收藏
分享
返回顶部
顶部