Puma 5.6.0 发布,关注高并发的 Ruby HTTP 服务器

来源: OSCHINA
编辑: 罗奇奇
2022-01-27 07:18:23

Puma 是一个简单、快速、线程化并且关注高并发的 HTTP 1.1 服务器,适用于开发和生产中的 Ruby/Rack 应用。

Puma 5.6.0 发布了,该版本带来如下变更:

特性

  • 支持在 ssl_bind 中集成本地主机 ([#2764],[#2708])
  • 允许使用 ssl_bind DSL 设置 backlog 参数 ([#2780])
  • 删除 StateFile 中的 yaml (psych)需求 ([#2784])
  • 添加 worker_check_interval 配置选项([ #2759 ])
  • 始终向客户端发送低级错误响应([ #2731 ],[ #2341 ])
  • 使用 ssl_bind DSL 支持 cert_pem 和 key_pem ([ #2728 ])

Bug 修复

  • 线程名保持在15个字符以下,防止在某些操作系统上出现中断 ([#2733])
  • 修复两个“老式定义”的编译警告 ([#2807], [#2806])
  • 正确使用选项值来记录环境 ([#2799])
  • 修复 Ruby master 的警告(将启用 3.2.0 版本) ([#2785])
  • extconf.rb - 用旧的 Windows 版本修复 openssl ([#2757])
  • server.rb - 新增对 @notify.close 的救援处理(Errno::EBADF) ([#2745])

重构

  • server.rb - 使用 [:remote_address] 重构代码 ([#2742])
  • [jruby] 一些避免复制字节的重构  ([#2730])

 

此外,Puma 的维护者之一 @nateberkopec 的女儿刚诞生,小名叫 Birdie,因此 Puma 5.6.0 版本也叫 “Birdie 版本”。

更新公告:https://github.com/puma/puma/releases/tag/v5.6.0

展开阅读全文
0 收藏
分享
1 评论
0 收藏
分享
返回顶部
顶部
返回顶部
顶部