Guice 5.1.0 发布,增加对 Java 17 的支持

来源: OSCHINA
编辑: 罗奇奇
2022-01-26 07:22:27

Guice 5.1.0 发布了, Guice 是 Google 开发的轻量级依赖注入框架,目标是使开发和调试更容易,更快速。

Guice 核心

  • 增加了对 Java 17 的支持,更新了 asm 版本并修复了不安全类定义
  • 支持 TYPE_USE 类型的 @Nullable 注解。
  • 改进了多重绑定,以避免不必要的链接绑定。
  • 添加了用于访问 SPI  InterceptorBindings  的 API。
  • 删除了 guice_include_stack_traces 标志的 COMPLETE 选项。

AssistedInject

  • 修复了 JDK17+ 私有查找行为。

Dagger Adapter

  • 如有必要,在 DaggerAdapter 中实例化模块。

Servlet

  • 修复了 UriEncoder 中解释和剥离数字前缀的错误。

更新公告:https://github.com/google/guice/wiki/Guice510

展开阅读全文
1 收藏
分享
2 评论
1 收藏
分享
返回顶部
顶部
返回顶部
顶部