Spring Boot 2.5.5 正式版发布

来源: 投稿
作者: mateplus
2021-09-23

一、发布说明

9月23日官方发布了Spring Boot 2.5.5版本,此版本包括41个错误修复、文档改进和依赖项升级。

二、更新内容

2.1 bug修复

  • 修复执行器端点默认情况下不会清理 SPRING_APPLICATION_JSON #28081
  • 使用 Flyway 和 Spring Integration 的 DataSource 初始化时由于非空模式下导致启动失败#28079
  • 当过滤器抛出 NestedServletException 以外的异常时,Web MVC 指标可能具有错误的状态#28069
  • 当存档文件名包含 URL 中保留的字符时,嵌入式 Undertow 抛出 MalformedURLException #28032
  • 并发镜像构建导致删除构建器镜像时出错#27993
  • 独立 Tomcat 中的 War 部署会导致内存泄漏(元空间)#27987
  • 运行大于 4GB的 Zip64 jar 文件时出现 IndexOutOfBoundsException #27900
  • 在 Windows 上未正确检测到 Azure 应用服务#27819
  • @MockBean结合@Repeat时出现“the field cannot have an existing value”错误#27798
  • 当路由数据源的目标具有空路由键时,RoutingDataSourceHealthContributor 中出现 NullPointerException #27698

 

2.2 文档

  • 使用 AspectJ weaving 时 devtools 重启不起作用的文档#28083
  • spring.data.elasticsearch.client.reactive.endpoints 的默认值没有记录 #28072
  • 澄清 Selenium 自动配置需要 HtmlUnit #27943
  • spring-boot-starter-parent 配置Java编译使用-parameters的文档#27885
  • 修复不一致的开发工具文档#27876
  • 修复 javadoc 中的错字#27873
  • 记录如何使用 WebTestClient 参数化 REST 文档的输出目录#27803
  • Java 17 的文档支持#26767

 

2.3 依赖升级

  • 升级至 Ehcache3 3.9.6 #27974
  • 升级至 Glassfish EL 3.0.4 #27975
  • 升级至 Groovy 3.0.9 #27976
  • 升级至 Gson 2.8.8 #27977
  • 升级至 Jackson Bom 2.12.5 #27978
  • 升级至 Jetty EL 9.0.52 #27979
  • 升级至 jOOQ 3.14.15 #28088
  • 升级至 Kotlin 1.5.31 #28089
  • 升级至 Kotlin Coroutines 1.5.2 #27982
  • 升级至 Lettuce 6.1.5.RELEASE #28031
  • 升级至 Logback 1.2.6 #27983
  • 升级至 Maven War Plugin 3.3.2 #27984
  • 升级至 Micrometer 1.7.4 #27916
  • 升级至 Netty 4.1.68.Final #27985
  • 升级至 Netty tcNative 2.0.43.Final #27986
  • 升级至 Reactor 2020.0.11 #27914
  • 升级至 SendGrid 4.7.5 #28109
  • 升级至 Spring Data 2021.0.5 #27917
  • 升级至 Spring Framework 5.3.10 #27915
  • 升级至 Spring HATEOAS 1.3.4 #27970
  • 升级至 Spring Integration 5.5.4 #27949
  • 升级至 Spring Kafka 2.7.7 #27918
  • 升级至 Tomcat 9.0.53 #27963
展开阅读全文
5 收藏
分享
加载中
最新评论 (3)
微服务Spring Cloud Alibaba同步完成版本升级:https://gitee.com/matevip/matecloud
2021-09-23 18:57
0
回复
举报
Spring Boot 2.3.12 Spring Cloud Hoxton.SR12 Spring Cloud Alibaba 2.2.6.RELEASE Nacos 2.0.3没问题
Spring Boot 2.5.5 Spring Cloud 2020.0.4 Spring Cloud Alibaba 2021.1 Nacos 2.0.3有问题,获取不到配置文件
2021-09-24 09:32
0
回复
举报
添加如下依赖
<dependency>
<groupId>org.springframework.cloud</groupId>
<artifactId>spring-cloud-starter-bootstrap</artifactId>
</dependency>
2021-09-24 10:31
0
回复
举报
更多评论
3 评论
5 收藏
分享
返回顶部
顶部