Apache Ant 1.9.16 和 1.10.11 发布,自动化构建工具

来源: OSCHINA
编辑: 局长
2021-07-21

Apache Ant 1.9.16 和 1.10.11 已发布,这也是目前正在维护的两个分支——1.9.x 和 1.10.x。前者要求 Java 5 以上,后者要求 Java 8 以上。1.9.x 系列主要是修复 bug,1.10.x 会增加新功能,两个分支都以 Ant 1.9.7 为基础。除非在构建过程中需要使用 Java 8 之前的版本,否则最好还是使用官方推荐的 1.10.x 分支。

最新发布的两个版本都修复了潜在的拒绝服务漏洞,详情查看 https://ant.apache.org/security.html

1.10.11 主要变化

  • 修复当并行运行任务时,一个竞争条件可能导致 NullPointerExceptions 的问题
  • 修复在使用 tar 或 zip 格式或从 zip 派生的格式读取受破损的档案时可能出现的 OutOfMemory 错误
  • 将 AntUnit 升级至 1.4.1 版本

1.9.16 主要变化

  • 修复发布到 Maven 中央仓库的 ant-testutil-sources.jar 不包含任何源代码文件的错误
  • 修复在使用 tar 或 zip 格式或从 zip 派生的格式读取受破损的档案时可能出现的 OutOfMemory 错误
  • 将 AntUnit 升级至 1.4.1 版本

下载地址

https://ant.apache.org/bindownload.cgi(二进制文件)
https://ant.apache.org/srcdownload.cgi(源码)

展开阅读全文
3 收藏
分享
加载中
最新评论 (7)
刚开始学Java的时候用过这个,真的是老古董了。
2021-07-23 11:22
0
回复
举报
这货居然还有更新?
2021-07-21 18:44
0
回复
举报
额,很少人用了吧
2021-07-21 15:54
0
回复
举报
被maven gradle打得满地找牙
2021-07-21 08:40
0
回复
举报
现在还使用 Ant 的都是老传统研发
2021-07-21 08:10
0
回复
举报
准确的说是古老遗留项目。
2021-07-21 09:50
0
回复
举报
认知太局限了
2021-07-21 10:47
2
回复
举报
更多评论
7 评论
3 收藏
分享
返回顶部
顶部