Android Studio Bumblebee Canary 3 发布

来源: 投稿
作者: 御坂弟弟
2021-07-10

Android Studio Bumblebee Canary 3 现已发布,此次更新主要修复了以下问题。

  • Android Gradle 插件
    • 采用默认 res 支持 (false) 的测试装置仍然有 resvalue 生成的文件夹
    • 在 gradle-api 中需要一个 Version 接口
    • AGP 4.2.0 会生成缺少类的测试 APK,可能是由混合的 java/kotlin 源代码集所致
    • 下一个要公开的工件应为 CLASSES
    • 注入的 Android 支持版本 “202.7660.26.42.7322048” 无效,格式应为 “wxyz”- 在执行 Compose 示例时收到此错误
    • 重新启用 DSL 创建 vis 实现类,而不是接口
  • Android Studio
    • UI_MODE_NIGHT_YES 无法在预览版中使用
  • 布局编辑器
    • TextClock 对象的布局预览有问题
    • 预览版与正在运行的应用不完全一样,?attr 在 XML [矢量可绘制对象] 的 fillColor 中不受支持
    • 添加 “androidx.preference:preference:1.1.0” 后,Android Studio 布局预览将无法用于原生 android.preference.Preference 和自定义偏好设置
    • Android Studio 4.0 缩放灵敏度
    • 布局渲染引擎:更新 strings.xml 时缺少 Unicode 字符
    • Android Studio 崩溃
  • lint
    • lint 循环假正例
    • Android lint 在特定项目中无法查看 androidx.annotation jar
    • @CheckResult 在 lambda 表达式中不起作用
    • “UnknownIssueId” 停用后仍会输出警告
    • UnusedResources lint 检查不能针对库正常运行
    • 使用 firebase-perf [OutdatedLibrary] 时,即使使用最新版本,也会发生 lint 错误
  • 渲染
    • 具有透明形状的可绘制对象未正确渲染
  • 资源
    • 升级到 4.2 后,某些字符串资源中添加了空格
  • 视图绑定
    • 使用膨胀视图绑定“inflate”方法的静态导入会导致出现未使用的资源
  • Wear 与 Google 助理配对
    • 无法从 IJ 启动 Wear 与 Google 助理的配对

详情请查看更新公告

展开阅读全文
0 收藏
分享
加载中
更多评论
0 评论
0 收藏
分享
返回顶部
顶部