Spring Boot 2.4.8 发布

来源: 投稿
作者: 御坂弟弟
2021-06-25

Spring Boot 2.4.8 现已发布。此版本包括 33 个错误修复、文档改进和依赖项升级。

主要更新内容

  • EnvironmentPostProcessors 未使用正确的 ClassLoader 进行实例化
  • 将不存在的类的名称绑定到 Class<?> 属性时失败
  • 处理 “spring.config.import” 属性时仍应发生特定于配置文件的解析
  • 如果已设置 kotlin.version 额外属性,则不应读取 Kotlin 插件的版本
  • 禁用自动计时时 MetricsClientHttpRequestInterceptor 中的内存泄漏
  • 在依赖于 org.springframework.boot:spring-boot-configuration-processor 的项目中使用配置缓存时,Gradle 构建失败并显示 “不支持在执行时调用 ‘Task.project’”
  • 在类路径上使用带有 spring.flyway.url 或 spring.liquibase.url 且没有 spring-jdbc 的 Flyway 或 Liquibase 时,应用程序无法启动
  • BeanNotOfRequiredTypeFailureAnalyzer 报告的误导性类型信息
  • DevTools 的 LiveReload 支持的 HTTP 标头处理区分大小写
  • 无法排除对重新打包的依赖
  • spring.datasource.name 属性描述不准确
  • RandomValuePropertySource 中的文档 uuid 支持
  • 更新参考文档以反映 @SpringBootApplication 对 @SpringBootConfiguration 的使用
  • 使文档版本更加明显

详情请查看更新公告

展开阅读全文
5 收藏
分享
加载中
精彩评论
您好,完全不兼容的,需要改动大量代码,不建议升级。
2021-06-25 14:19
2
举报
最新评论 (10)
您好,请问java cron多个任务可以配置成同一个时间执行吗?会覆盖吗?
2021-06-26 08:03
0
回复
举报
您好,您是不是搞错了,cron是一个表达式,和 java 没有关系, java 是一门编程语言。
2021-06-28 09:15
0
回复
举报
别说2.3, 2.2了, 大概率跟2.4.7都不兼容
2021-06-26 06:06
0
回复
举报
您好,请问向下兼容吗?
2021-06-25 10:37
0
回复
举报
您好,完全不兼容的,需要改动大量代码,不建议升级。
2021-06-25 14:19
2
回复
举报
https://gitee.com/matevip/matecloud
已经升级至2.5.2版本,可供参考
2021-06-25 22:58
0
回复
举报
2021-06-25 10:36
1
回复
举报
今天刚刚发布了 2.5.2
2021-06-25 14:24
0
回复
举报
2.4系列和2.5系列不一样的吧。
2021-06-25 14:35
0
回复
举报
你慢点升级,我还在用1.5呢
2021-06-25 10:17
0
回复
举报
更多评论
9 评论
5 收藏
分享
返回顶部
顶部