DataGrip 2021.1.3 发布,多引擎数据库平台

来源: 投稿
作者: 御坂弟弟
2021-06-09

DataGrip 2021.1.3 现已发布,这是 DataGrip 2021.1 的第三个错误修复版本。

主要更新内容

  • 处于安全方面的考虑,Java 放弃了对 TLSv1 和 TLSv1.1 协议的使用。这会在连接到只接受这些协议的旧服务器出现问题。作为修复,DataGrip 现在提供了明确打开这些协议的能力,不过用户需要记住,这样做会导致一些漏洞问题

  • 即使数据库支持 TLSv1.2 和 TLSv1.3 协议,连接到 MySQL 也可能出现问题。由于服务器端的错误,驱动程序禁用了对这些版本的 TLSv1.2 和 TLSv1.3 支持。用户可以尝试启用它们。但如果服务器返回一个 "bad handshake" 的错误,请禁用这些版本

  • 代码完成现在可以在修改表中工作,即使案例不匹配
  • [SQL Server] 生成的 DDL 中不包含扩展属性
  • [Oracle] Introspection 与版本 9i 兼容

详情请查看更新公告

展开阅读全文
1 收藏
分享
加载中
最新评论 (1)
有社区版本吗
2021-06-09 12:21
0
回复
举报
更多评论
1 评论
1 收藏
分享
返回顶部
顶部