Android Studio Bumblebee Canary 1 发布

来源: 投稿
作者: 御坂弟弟
2021-05-27

Android Studio Bumblebee Canary 1 现已发布,此次更新主要修复了以下问题。

Android Gradle Plugin

  • 对于未知标志 --class-dir,使用 --help 获取使用信息
  • 不要对 DefaultLintModelVariant.shrinkable 进行硬编码
  • 支持依赖库中的应用模块安装
  • AGP 7.0.0 Alpha 15 抛出未解决的引用:missingDimensionStrategy
  • Android Lint VectorDrawableCompat 检查发出错误的警告
  • buildConfigField 替换警告打印出的值,可能包含敏感信息
  • ASM 转换的配置缓存问题
  • com.android.databinding:baseLibrary 使用支持遗留库

Build Tools

  • 在AGP 4.2.0-rc01 中,lint.xml 文件被忽略

Build Variants

  • 对于 Kotlin/Kapt 来说,切换缓存变体不能正确工作
  • Build variant 部分总是空的(加载中)
  • 复合构建根项目在构建变体选择器工具窗口中显示为 ":"

Code Analysis

  • Android lint 显示 API 级别检查的误报,以获取已继承的接口中的字段

Import/Sync

  • Android Studio 用 "assemble" 而不是 ":app:assembleDebug" 进行构建
  • Manifest 索引无法识别生成文件夹中的清单
  • 没有办法在构建变量选择工具窗口中搜索模块

Lint

  • 当 LintOptions.absolutePaths 为假时,绝对路径出现在部分结果文件中
  • 新的 lint 集成中的 RestrictedApi 检测器的潜在问题
  • RestrictToDetector 抛出 StringIndexOutOfBoundsException
  • 通过 lintOptions.enable 启用的问题总是有严重性警告。
  • 当只有测试类时,Lint 会给出失败的分析结果
  • ExifInterfaceDetector 的 Lint 检查指的是过时的类
  • Lint 日志中的垃圾邮:"不正确的检测器报告禁用问题 ExtraTranslation"

详细内容请查看更新公告

展开阅读全文
0 收藏
分享
加载中
最新评论 (1)
升级后插件编译错误,太恶心了
2021-05-27 14:06
0
回复
举报
更多评论
0 评论
0 收藏
分享
返回顶部
顶部