IntelliJ IDEA 2021.1 首个 Beta 版本发布

来源: OSCHINA
编辑: 局长
2021-03-08

经过了近五周的 EAP 版本更新后,IntelliJ IDEA 2021.1 终于发布了首个 Beta 版本。

主要更新亮点:

  • 支持 Java 16
  • 支持打开存储在 WSL 2 中的 Maven 和  Gradle 文件,并在 WSL 2 环境中进行使用
    开发团队已发现此功能存在的问题,目前进行修复
  • 新增 Run Targets 功能,可帮助用户在 Docker 容器或远程机器上运行、测试和调试应用程序
  • 集成 Space 并支持开箱即用
  • 绑定 Code With Me——这是一个用于协作开发和结对编程的服务
  • 支持在 IDE 内部预览 HTML
  • 重新设计的 Profiler UX
  • 支持调节字体粗细
  • 支持 JSONPath
  • Framework 改进

支持 Java 16

JDK 16 预计于 2021 年 3 月发布。IntelliJ IDEA 表示,其已经已经在“文件|项目结构|模块”中添加了新的语言级别,还引入了对 Java 16 的基本支持,包括以下更新:

  • 内部类现在可以声明显式或隐式静态的成员。

  • Stream.collect(toUnmodifiableList()) 被转换为 stream.toList()。现在,toList() 项首先显示在 stream 的 code completion list 中。

支持 WSL 2

当用户的 IDE 在 Windows 上运行时,IDEA 将提供对 WSL 2 内的 Java 项目的初步支持。IntelliJ IDEA 现在可以在 WSL 2 中执行以下操作:检测 JDK 安装、安装 JDK,以及使用 IntelliJ IDEA 构建系统编译和运行项目。此外还支持打开存储在 WSL 2 中的 Maven 和  Gradle 文件。

Run Targets

从 2021.1 开始,新的 Run Targets 功能将允许用户在 target 上运行、测试和调试应用程序 — IDE 将在其中执行代码的已配置环境。

IntelliJ IDEA Ultimate 目前允许用户在 Docker、SSH 和 WSL target 上运行 Java 应用程序、JUnit 测试和来自 Java、Maven 和 Spring Boot 项目的 Maven 命令。

支持调节字体粗细

支持 JSONPath

IntelliJ IDEA 支持使用 Goessner 和 Jayway 语法的 JSONPath 表达式。

下载地址 | 发布公告

展开阅读全文
1 收藏
分享
加载中
精彩评论
"支持在 IDE 内部预览 HTML" 完蛋,越来越卡了,eclipse就是支持预览超卡。idea也越来越臃肿了。
2021-03-08 21:47
1
举报
插件又要完蛋
2021-03-08 09:27
1
举报
插件鸡鸡
2021-03-08 08:24
1
举报
最新评论 (20)
lombok,阻止idea升级永远的神
2021-03-09 14:54
0
回复
举报
2020.3已经内置lombok了
2021-03-13 14:21
0
回复
举报
IDE 跟 eclipse 相爱相杀
2021-03-09 12:59
0
回复
举报
插件gg是正常的
2021-03-08 23:29
0
回复
举报
"支持在 IDE 内部预览 HTML" 完蛋,越来越卡了,eclipse就是支持预览超卡。idea也越来越臃肿了。
2021-03-08 21:47
1
回复
举报
我用的R7 4750G+32G内存,这功能更好了
2021-03-09 11:17
0
回复
举报
Run Targets 可以可以可以
2021-03-08 19:23
0
回复
举报
您好,请问内部类可以多层内部类嵌套吗?java语法支持吗?这些特殊的java语法在哪看官方标准?
2021-03-08 09:31
0
回复
举报
插件又要完蛋
2021-03-08 09:27
1
回复
举报
m1 上等这些工具适配完善 至少都要等到明年去了。
2021-03-08 09:14
0
回复
举报
那我刚官网定了一台m1
2021-03-08 11:01
0
回复
举报
我还在犹豫,要不要买,主要是小问题太多了,还有些开发工具不是原生支持
2021-03-08 14:40
0
回复
举报
M1哪个没适配?用过吗
2021-03-09 09:30
0
回复
举报
2020.3就适配啦
2021-03-11 10:20
0
回复
举报
mac能启动不?
2021-03-08 08:47
0
回复
举报
早就适配了m1
2021-03-08 16:53
0
回复
举报
好吧,我自己本地无法启动,早期EAP无法启动现在的beta也无法启动,昨天按照官方的文档删除了点东西就好了
2021-03-09 08:56
0
回复
举报
在2020.3的版本就已经支持M1芯片了
2021-03-11 10:16
0
回复
举报
不是M1,我的是2018款MBP,之前下了几次EAP都无法启动然后直接卸载了,后来发现是旧版本的配置文件啥的都要删掉才能正常启动
2021-03-14 22:29
0
回复
举报
插件鸡鸡
2021-03-08 08:24
1
回复
举报
更多评论
20 评论
1 收藏
分享
返回顶部
顶部