pip 21.0 停止支持 Python 2 和 Python 3.5

来源: OSCHINA
编辑: 局长
2021-01-26

Python 包管理器 pip 21.0(尚未发布) 的 Changelog 显示,此版本最重要的变化是停止支持 Python 2 以及 Python 3.5。Python 2 于2020年1月退休,Python 3.5 于2020年3月退休,两者均不再受到支持。

虽然 Python 2 结束维护的时间是2020年1月,不过它最后一个版本 2.7.18 的发布时间是2020年4月。

pip 停止支持 Python 2 关联的 issue 显示,此 issue 早在2019年就已提交,不过直到去年年底才真正完成。此外,2020年 pip 20.3 发布时,就已预告将取消支持 Python 3.5,并在 pip 21.0 中被移除。

对于用户来说,pip 停止支持 Python 2 带来的影响主要是无需担心安装面向 Python 3 的软件包时,由于输入 pip 而不是 pip3 而出现错误,毕竟 pip 生态已将 Python 2 移除。

延伸阅读

展开阅读全文
2 收藏
分享
加载中
精彩评论
支持个锤。Python3.6以下,很多特性不行,应当淘汰。
2021-01-26 09:52
7
举报
最新评论 (4)
现在用python 3.8.5。。。
2021-01-28 13:39
0
回复
举报
确实应该停止这些老版本,不然割裂太严重,缩紧是有好处的
2021-01-26 15:05
0
回复
举报
3.5都不支持
2021-01-26 09:11
0
回复
举报
支持个锤。Python3.6以下,很多特性不行,应当淘汰。
2021-01-26 09:52
7
回复
举报
更多评论
4 评论
2 收藏
分享
返回顶部
顶部