Pika 3.4.0 发布,从单机到集群

来源: OSCHINA
编辑: 一君_
2020-12-02

pika 3.4.0 发布了。pika 是 360 公司发布一个可持久化的大容量 redis 存储服务,兼容 string、hash、list、zset、set 的绝大部分接口,解决 redis 由于存储数据量巨大而导致内存不够用的容量瓶颈。360 推出原生分布式 pika 集群,发布 pika 3.4.0,pika 原生集群不再需要额外部署 codis-proxy 模块。

新增功能:

  • sharding 模式下内置 pika proxy 组件,自动代理客户端请求到响应 slot 节点。
  • proxy 支持根据业务压力配置后端连接数。
  • proxy 支持后端连接自动保活机制。
  • proxy 支持 slot 共享后端连接。
  • proxy 支持客户端 pipline 功能。
  • proxy 支持 slot 主从切换,slot 数据迁移功能。
  • proxy 支持 hash tag 功能。用户可以通过 hash tag 把 key 存储到指定的 slot。
  • pika 支持 protocol buf 管理接口。

注意事项:

  • 分片模式和经典模式不可兼容,请在启动时候配置好启动模式
  • 副本一致性可配置功能目前只支持分片模式。
  • 分片模式下取消 slaveof 命令,使用 pkcluster slotsslaveof 替代,详细见 Pika 分片命令
  • 经典模式下取消 info log 命令,info log 的 binlog offset 移至 info replication,info log 的 binlog size 移至 info data
  • 分片模式下取消 info replication 命令,用 pkcluster info slot 替代
  • 由于redis-cli 对于数据展示格式限制,对于 pkcluster info slot 的数据展示格式不够人性化。可以自行修改 redis-cli 代码 redis-cli modification
  • pika 从 2.1.4 推荐需要使用 gcc 4.8+ 版本编译,更新 gcc 后执行 make distclean && make 编译
  • pika3.1.0 版本之后不再支持双主
  • pika3.1.0 版本使用 pb 协议进行内部通信,不能直接和之前的版本建立主从关系,由低版本升级到 pika3.1.0 可以参照 wiki 进行升级(如何升级到 Pika3.0如何升级到 Pika3.1
  • 由于 zset 精度的优化(自 pika3.0.0 起 zset 精度已与 redis 一致),如果你在低版本的 pika(<3.0.0)中使用了 geo 功能,请在将其升级到 pika3.0 时不要直接使用 nemo_to_blackwidow 工具进行 geo 相关 zset(其它结构的数据不受影响)数据的迁移,否则由于精度差异问题,迁移后的 geo 数据将损坏,建议使用客户端将 geo 相关 zset 数据重新导入。
  • 3.3.0 以后的版本包含了日志复制一致性的功能,建议使用该功能的用户使用版本 3.3.6。
  • 为了保证服务的稳定,建议不使用日志复制一致性的用户升级至 3.2.9。
  • 目前停止对 3.0 版本的维护

发布说明:https://github.com/Qihoo360/pika/releases

相关阅读:https://my.oschina.net/u/4063048/blog/4763385

展开阅读全文
2 收藏
分享
加载中
更多评论
0 评论
2 收藏
分享
返回顶部
顶部