Dart 2.10 发布,带来新的 Dart 开发者工具

2020年10月05日

Dart 2.10 版本发布了。此版本具有一个新的、统一的 Dart 开发者工具:一个可以满足所有开发者需求的工具,例如创建项目、分析和格式化代码、运行测试以及编译应用程序。Dart 开发团队还对 null safety 路线图和时间表进行了更新,并讨论了将现有代码迁移到 null safety 的原理。

新的 Dart 开发者工具

Dart 2.10 具有一个新的、统一的 Dart 开发者工具,与 Flutter 工具非常相似。这个新工具支持所有常见任务,例如创建新项目和程序包;分析和格式化代码;以及运行、编译和测试项目。

要使用该工具,只需运行 dart 命令:

Flutter 在 Flutter SDK 中已经包含了这个新的 Dart 工具。从 Flutter 1.22 SDK 开始, <flutter-sdk>/bin 同时包含 flutter 和 dart 命令。如果同时进行 Flutter 开发和通用 Dart 开发,则可以通过单个 Flutter SDK 满足开发需求,而无需安装其他任何东西。

开发团队计划在此 dart 工具中添加更多功能,并逐步弃用较小的工具(dartdoc、dartfmt、dartanalyzer 等)。明年预计会发布仅包含单个 dart 工具的 Dart SDK。

null safety

官方表示期盼将空值安全性作为避免空值错误的工具,并且期望通过可靠的空值安全性来实现性能提升。

至于何时可用上 null safety,以下是时间表:

  • Flutter 实验(技术预览 2):已成功迁移了 Flutter 的大部分内容。预计在下个月之内迁移完整的 Flutter 框架,准备在 Flutter 上进行实验性使用。
  • 早期的程序包迁移(Beta):今年晚些时候将完成性能调整,并进行足够的测试,以确保该功能可以按预期运行,以及确保向后兼容是可靠的。
  • 稳定使用的生产环境:根据 Beta 测试版发布的反馈,修复所有剩余问题,然后发布到稳定状态。很难为此设定一个具体的时间表,目前的考虑是明年年初。

详情可查阅发布公告

展开阅读全文
2 收藏
分享
加载中
精彩评论
已经用上了
2020-10-05 20:38
1
举报
最新评论 (15)
闲鱼的输入框一使用空格快速定位,就会出现UI卡死的bug,这是闲鱼的毛病,还是flutter的毛病。
2020-10-11 23:34
0
回复
举报
dart是我最喜爱的编程语言
2020-10-10 16:10
0
回复
举报
您好,请问这种编程软件底层绘图是怎么实现的?需要对接不同硬件的绘图接口吗?还是对接openGL就可以?
2020-10-09 18:23
0
回复
举报
OpenGL、Metal
2020-10-10 08:53
0
回复
举报
为什么我试用过的Flutter APP,列表滚动都非常卡顿?开发者的问题,还是Flutter本身的问题?
2020-10-07 10:59
0
回复
举报
我的也是,android有卡顿
2020-10-09 08:55
0
回复
举报
手机的问题,哈哈 性能不够
2020-10-09 11:19
0
回复
举报
打个release版本看看,debug版的确有点卡。
2020-10-09 11:27
0
回复
举报
?
2020-10-09 14:04
0
回复
举报
闲鱼挺流畅的
2020-10-09 15:42
0
回复
举报
经常闪退
2020-10-09 21:00
0
回复
举报
咸鱼不卡
2020-10-09 17:56
0
回复
举报
手机不能太差, release版本会比debug版本快很多
2020-10-10 09:22
0
回复
举报
别人发布的app,应该都是release的吧?
我手机性能确实不咋的,但用原生开发的app,列表滚动还是流畅的。所以我觉得不能怪手机性能~~
2020-10-10 16:50
0
回复
举报
已经用上了
2020-10-05 20:38
1
回复
举报
更多评论
15 评论
2 收藏
分享
返回顶部
顶部