Angular 10 版本现已发布

GuoMengyue
 GuoMengyue
发布于 2020年06月28日
收藏 3

疫情下高薪offer怎么拿?华为4条技术指南轻松应对!(内含求职、租房攻略)>>>

版本10.0.0在这里!这是涵盖整个平台的主要发行版,包括框架,Angular Material和CLI。此发行版小于典型发行版。自从我们发布Angular 9.0版本以来只有四个月。

蝴蝶海滩照片,Minko Gechev摄

我们尝试每年发布两个主要版本,以使Angular与其他JavaScript生态系统保持同步并制定可预测的时间表。我们计划在今年秋天发布版本11。

此版本中有什么?

新日期范围选择器

Angular Material现在包括一个新的日期范围选择器。

新的日期范围选择器的图像

要使用新的日期范围选择器,可以使用mat-date-range-inputmat-date-range-picker组件。

请参阅StackBlitz上的示例

了解有关日期范围选择的更多信息。

有关CommonJS导入的警告

当您使用CommonJS打包的依赖项时,它会导致应用程序变慢

从版本10开始,当您的构建引入这些捆绑软件之一时,我们现在向您发出警告。如果您开始对依赖项看到这些警告,请让您的依赖项知道您更喜欢ECMAScript模块(ESM)捆绑包。

CommonJS或AMD依赖项可能导致优化援助

可选的更严格设置

当您使用创建新工作区时,版本10提供了更严格的项目设置ng new

ng new --strict

启用此标志会使用一些新设置初始化您的新项目,这些设置可以改善可维护性,帮助您提前捕获错误并允许CLI在您的应用上执行高级优化。具体来说,该strict标志执行以下操作:

  • 在TypeScript中启用严格模式
  • 将模板类型检查设置为“严格”
  • 默认捆绑广告预算已减少了约75%
  • 配置起毛规则以防止类型声明any
  • 将您的应用配置为无副作用,以实现更高级的树状摇动

与生态系统保持同步

与往常一样,我们对Angular的依赖项进行了一些更新,以与JavaScript生态系统保持同步。

我们还更新了项目布局。从版本10开始,您将看到一个新的tsconfig.base.json。此附加tsconfig.json文件更好地支持IDE和构建工具解析类型和程序包配置的方式。

新的默认浏览器配置

我们已经为新项目更新了浏览器配置,以排除较旧和较少使用的浏览器。

v9默认值

v10默认值

这具有默认情况下为新项目禁用ES5构建的副作用。要为需要它的浏览器(例如IE或UC Browser)启用ES5构建和差异加载,只需在文件中添加需要支持的浏览器即可.browserslistrc

Angular Team Fixit

我们大大增加了与社区合作的投资。在过去三周中,我们的未解决问题数量减少了700多个构架, 工具和 组件。我们已经解决了2,000多个问题,并且计划在未来几个月内进行大量投资,与社区合作,做更多的事情。

弃用和移除

我们对Angular进行了一些新的弃用和删除。

角包格式不再包括ESM5或FESM5束,运行时为您节省下载119MB并安装时间yarnnpm install对角的包和库。不再需要这些格式,因为在构建过程结束时将完成任何降级以支持ES5。

在与社区进行大量协商的基础上,我们将不再支持旧版本的浏览器,包括IE 9、10和Internet Explorer Mobile

您可以阅读有关我们的弃用和清除的更多信息

如何更新到版本10

请访问update.angular.io以获取详细信息和指导。为了获得最佳的更新体验,我们建议始终一次升级一个主要版本。

更新:

ng update @ angular / cli @ angular / core

您可以在《更新到版本10指南》中阅读有关此更新的更多信息。

翻译自:https://blog.angular.io/version-10-of-angular-now-available-78960babd41

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Angular 10 版本现已发布
加载中
此新闻有 22 条评论,请先登录后再查看。
返回顶部
顶部