Ruby 2.4 结束支持

来源: OSCHINA
编辑: oschina
2020-04-30

官方宣布,对 Ruby 2.4 系列的支持全部结束。

自去年 3 月底开始,Ruby 2.4 系列进入安全维护阶段。一年过去了,这个阶段告一段落。因此,自 2020 年 3 月 31 日起,对 Ruby 2.4 系列的支持全部结束。来自 Ruby 较新版本的缺陷和安全修正不再移植到 2.4 系列,也不再发布 2.4 的补丁版本。Ruby 开发团队于 2020 年 3 月 31 日发布了 Ruby 2.4.10,但这是出于给用户一点时间来迁移到更新的版本。强烈建议尽快升级到更新的版本。

关于目前支持的 Ruby 版本

Ruby 2.7 系列

目前处于常规维护阶段。必要时会移植缺陷修正,发布新版。如果发现严重安全问题,会发布紧急修正版。

Ruby 2.6 系列

目前处于常规维护阶段。必要时会移植缺陷修正,发布新版。如果发现严重安全问题,会发布紧急修正版。

Ruby 2.5 系列

目前处于安全维护阶段。除了安全修正之外,不再把缺陷修正移植到 2.5 系列。如果发现严重安全问题,会发布紧急修正版。另外,对 Ruby 2.5 系列的支持计划在 2021 年 3 月底结束。

稿源 https://www.ruby-lang.org/zh_cn/

展开阅读全文
0 收藏
分享
加载中
更多评论
0 评论
0 收藏
分享
返回顶部
顶部