Node.js 13.8.0、12.15.0 与 10.19.0 发布,修复安全漏洞

oschina
 oschina
发布于 2020年02月08日
收藏 1

Node 连发了 13.8.012.15.0 与 10.19.0 三个安全版本,修复了几个漏洞:

  • CVE-2019-15606:HTTP header 值没有修剪尾随的 OWS。
  • CVE-2019-15605:使用异常的 Transfer-Encoding header 发起 HTTP 请求。
  • CVE-2019-15604:使用异常的证书字符串远程触发 TLS 服务器上的断言。

同时,现在 HTTP 解析更加严格,因此更加安全。但是由于这可能会导致与某些不一致的 HTTP 实现的互操作性问题,因此可以使用 --insecure-http-parser 命令行 flag 或 insecureHTTPParser http 选项禁用严格检查。应避免使用不安全的 HTTP 解析器。

详情查看每个版本的更新说明。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Node.js 13.8.0、12.15.0 与 10.19.0 发布,修复安全漏洞
加载中
返回顶部
顶部