JavaScript 包管理器 Yarn 2 或将以 berry 名称发布?

来源: OSCHINA
编辑: 局长
2020-01-27

昨天一名开发者(@brentvatne)在 Yarn 2 的 GitHub 仓库中提交了一个 issue,建议官方使用不同的名称来发布 Yarn 2。

brentvatne 表示,他自己是一名开源库的作者,一直在推荐他的用户通过 yarn 来使用他的开源库。然而到了 yarn v2,他不能再这样做了,因为 yarn v2 与 React Native 不兼容,所以与 yarn 也不兼容,最终导致 yarn v2 在许多项目中都无法使用。

针对此问题,brentvatne 提出了他的建议,他建议在 yarn PnP 被用于现有生态系统中所有主要项目之前,应该以其他名称发布它。如此一来,使用者可以轻松使用并从中获益,库作者也能保证他们的库能够正常使用。

Yarn 核心维护者 @arcanis 在 issue 的评论中进行了回应,他表示团队已经获悉并正在讨论此问题,更不希望破坏工作流程。目前 Yarn 2 的仓库使用 berry 名称的原因是为了与 1.x 进行区分,明确说明 1.x 分支不会发生任何变化。但如果要以 berry 软件包名称和 berry 二进制名称发布 CLI 二进制文件,这将会导致一定的混乱。arcanis 也提出了他的想法:

  • 将 Yarn 2 保留在 Yarn 组织内
  • 保持 yarnpkg.com / legacy.yarnpkg.com 的独立性
  • 继续以 @yarnpkg/<name> 的形式发布模块化软件包

展开阅读全文
2 收藏
分享
加载中
精彩评论
至少还得3年
2020-01-27 12:49
3
举报
最新评论 (6)
yarn 2 为什么不兼容 yarn 1 呢?
2020-01-29 17:39
0
回复
举报
估计Deno流行起来后就没这些包管理器啥事儿了
2020-01-27 11:40
0
回复
举报
至少还得3年
2020-01-27 12:49
3
回复
举报
到时候先问问墙可不可以
2020-01-27 20:20
0
回复
举报
deno和这些又没有冲突,就算deno取代v8,包管理器还是必须有的功能
2020-01-28 22:07
0
回复
举报
更名,会造成很多麻烦事儿,一般团体会直接寻找更稳定的套件吧
2020-01-27 09:47
0
回复
举报
更多评论
6 评论
2 收藏
分享
返回顶部
顶部