PostgreSQL 12.1、11.6、10.11、9.6.16、9.5.20 和 9.4.25 发布

xplanet
 xplanet
发布于 2019年11月15日
收藏 5

PostgreSQL 开发小组已经发布了对数据库系统所有受支持版本的更新,包括 12.1、11.6、10.11、9.6.16、9.5.20 和 9.4.25。此版本修复了过去三个月内报告的 60 多个错误。

部分修复内容如下:

  • 修复了当 ALTER TABLE 添加没有默认值的列以及需要重写表的其他更改时发生的崩溃
  • 针对 REINDEX CONCURRENTLY 的几个修复程序
  • 修复了 VACUUM,在特定情况下(包括仍在运行的事务),它可能会导致 VACUUM 失败
  • 修复了 VACUUM 在 GiST 索引上运行时可能发生的内存泄漏
  • 修复了在表达式索引上运行 CLUSTER 时发生的错误
  • 修复分区表上 SET CONSTRAINTS ... DEFERRED 的失败
  • 在分区表上创建和删除索引的几个修复程序
  • 修复了可能导致计划程序失败的分区联接
  • 确保在处理查询的表达式时处理 WINDOW 子句中的偏移量表达式
  • 修复 bitshiftright() 的错误行为,如果位字符串长度不是8的倍数,则它无法将最后一个字节的填充空间清零
  • ……

更新说明:https://www.postgresql.org/about/news/1994/

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:PostgreSQL 12.1、11.6、10.11、9.6.16、9.5.20 和 9.4.25 发布
加载中

最新评论(6

蔡小峰
蔡小峰
基于pg的分布式关系型数据库 还有 腾讯 TBase
Tinian
Tinian
为什么我在 Windows10 老是装不上,最后启动service错误
开源中国首席腰突
开源中国首席腰突
我windows10直接装最新版才可以,低版本出错。
ChangTian192
ChangTian192
用Linux,为什么要用Windows
冰力
冰力
用 Windows 桌面开发东西为啥不能用 Windows 装 PostgreSQL?
依剑_听雨
依剑_听雨
分布式版本 yugabytedb ,cockroachDB ,greenplum
返回顶部
顶部