Apache Ivy 2.5.0 发布,项目依赖管理工具

xplanet
 xplanet
发布于 2019年10月29日
收藏 6

时隔将近五年,Apache Ivy 终于发布了 2.5.0 版本。Apache Ivy 是一个优秀的管理(记录、跟踪、解析和报告)项目依赖的工具,可与 Apache Ant 紧密集成。新版主要更新内容如下:

  • 现在所需的最低运行时 Java 版本是 Java 7
  • Ivy 现在使用 BouncyCastle OpenPGP API 1.59。 由于该库的非向后兼容性,因此不支持早期版本。
  • 现在,Ivy 使用带有 HTTP 支持的解析器的 HttpComponents HttpClient 4.5.x 版本。 如果希望使用此类解析程序,则用户应在其运行时类路径中具有此版本的库(及其依赖项)。 前一个 commons-httpclient 库不再使用或受支持。

详情可查看发布公告

下载地址:https://ant.apache.org/ivy/download.cgi

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Apache Ivy 2.5.0 发布,项目依赖管理工具
加载中

最新评论(8

张寒枫
张寒枫
我们还在用,定制化比较灵活,jar包管理比较强
邪恶八稚女
邪恶八稚女
现在大部分应该都是Maven或者Gradle吧
TGVvbmFyZA
TGVvbmFyZA
ant用户不多吧
Shmily丶zZ
Shmily丶zZ
习惯mavne之后懒得折腾了
shatian
shatian
maven还没熟悉透彻,又出来一个lvy,我该不该学一下gradle
赤脚小子
赤脚小子
你这个说法有问题,IVY都多少年了早几年都是IVY然后才MAVEN普及,然后安卓出来了GRADLE才普及
shatian
shatian
不管谁前谁后吧,关键是学不动了
ddatsh
ddatsh
有多少人用..
返回顶部
顶部