Samba 4.11 发布,默认情况下禁用 SMB1

afterer
 afterer
发布于 2019年09月21日
收藏 5

Samba 是 Linux 和 Unix 程序的标准 Windows 互操作性套件。Samba 4.11 可以提供更好的 Windows、Linux 和其他平台的互操作性。Samba 4.11 中的更改非常多,其中主要亮点是具有很大的可伸缩性改进。

Samba 4.11 中的其他一些重大更改包括:

  • 将默认的流程模型更改为 prefork
  • 增强 Samba-Tool
  • 连接和重新索引操作的性能改进
  • 更好的 LDB 搜索性能和 CephFS 快照集成
  • 改变了 AD 数据库存储在磁盘上的方式

另外,Samba 4.11 支持 Python 3(代替 Python2),默认情况下禁用 SMB1 协议支持。还有,客户机/服务器最低协议版本已被设置为 SMB 2_02,这意味着不支持 SMB2 或 SMB3 的客户端不能够连接到 smbd,SMB1 未来也将被删除。Samba 4.11 仍与旧版本 Samba 的数据库兼容。

更多改进见发布说明:

https://www.samba.org/samba/history/samba-4.11.0.html

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Samba 4.11 发布,默认情况下禁用 SMB1
加载中
返回顶部
顶部