SpringBoot 增强库 yue-library 更新,你们要的 JDK8 版本来了

yl-yue
 yl-yue
发布于 2019年09月18日
收藏 40

logo

yue-library

yue-library是一个基于SpringBoot封装的基础库

  • 内置丰富的JDK工具
  • 自动装配了一系列的基础Bean与环境配置项
  • 快速构建SpringCloud项目,让微服务变得更简单

你们要的JDK8版本来了,基于Greenwich.SR2做兼容适配,收藏一波以表支持吧(≧▽≦)/!本次更新主要升级了SpringCloud版本与新增Pay模块、分离加解密模块。接下来计划添加oss、sms等模块。

点击查看完整的版本更新日志

Finchley.SR4【2019-09-16】

新特性

  • 你们要的JDK8版本来了,基于Greenwich.SR2做兼容适配
  • 版本升级注意:lombok 版本和 IDE lombok 版本一致,此版本完善了之前遗留下来的规范,导致部分类与方法失效,但所有失效类与方法都提供了指引说明
  • 升级基础依赖:SpringCloud:Finchley.SR4 SpringBoot:2.0.9.RELEASE hutool:4.6.2 fastjson:1.2.59
  • 新增 yue-library-base-crypto 模块,基于hutool提供更完善的加解密、签名等操作。提供自动配置全局单例
  • 新增 yue-library-pay 模块,基于pay-java-parent进行二次封装,让你真正做到一行代码实现支付聚合,让你可以不用理解支付怎么对接,只需要专注你的业务
  • 优化serialVersionUID
  • 完善文档-更详细的教程,更多的细节介绍和建议。
  • 【base】JSONObject 参数解析器 @PostMapping public Result<?> post(JSONObject paramJson) {
  • 【base】ApplicationContextUtils 普通类操作Spring上下文,更方面的SpringBean操作
  • 【base】ServletUtils 对Servlet操作的增强,迁入原有工具类 HttpUtils CookieUtils

工程结构

. yue-library
├── yue-library  基础库
│   ├── yue-library-dependencies  父pom
│   ├── yue-library-base          基础库提供了丰富的Java工具包,同时也自动装配了一系列基础Bean等
│   ├── yue-library-data-jdbc     基于SpringJDBC进行二次封装,拥有着强大性能的同时又不失简单、灵活等
│   ├── yue-library-data-redis    基于SpringRedis进行二次封装,更简单灵活,提供全局token与登录相关特性等
│   ├── yue-library-pay           基于pay-java-parent进行二次封装,让你真正做到一行代码实现支付聚合
│   ├── yue-library-cloud-oss
│   └── yue-library-cloud-sms
├── yue-library-samples  基础库示例
│   ├── yue-library-test			yue-library代码测试项目:单元测试、接口测试、代码示例
│   ├── yue-library-template-simple		yue-library模版:SpringBoot项目模版
│   └── yue-library-template-ssc		yue-library模版:SpringCloud项目模版,SOA共享架构(阿里巴巴中台)
└── yue

快速开始

引入项目依赖

maven项目,在pom.xml文件中添加如下一段代码,并将${version}替换为对应版本号:maven-central

<parent>
	<groupId>ai.ylyue</groupId>
	<artifactId>yue-library-dependencies</artifactId>
	<version>${version}</version>
</parent>

随后引入所需要的模块,如基础库:yue-library-base

<dependencies>
	<dependency>
		<groupId>ai.ylyue</groupId>
		<artifactId>yue-library-base</artifactId>
	</dependency>
	...
</dependencies>

版本说明

yue-library的版本命名方式,采用SpringCloud版本名作为前缀,然后以.1、.2、.3...这种形式,目的是为了方便区分所依赖的SpringCloud版本。

yue-library-base为其他模块的基础依赖(简称基础库),所以若需要引入除基础库之外的模块(如:data-jdbc、data-redis),可以不引入yue-library-base

JDK版本 JDK说明 SpringCloud版本 版本说明
JDK8 LTS(Oracle长期支持版本),目前大部分互联网公司采用版本 Finchley JDK8兼容版本,每次新特性发布都会进行一次全面的兼容适配与测试,以供JDK8用户稳定使用
JDK11 LTS(Oracle长期支持版本),作者采用版本 Greenwich JDK11推荐版本,提供更快速的迭代与反馈

配置与文档说明

yue-library自动装配了一系列的基础Bean与环境配置项,可在 <b>application.yml</b> 文件中配置关闭,所有配置项皆是以yue.*开头,如:yue.cors.allow=false代表不允许跨域,更多配置项与细节介绍,可查看 官方文档 中各模块的详细说明。

官方文档 提供各模块的详细介绍与使用示例,类与方法说明可参阅 API文档,SpringBoot项目基础模版可使用 yue-library-template-simple,单元测试代码与标准示例可参考:yue-library-test

结语

引用此项目作基础依赖,后续也可很好的对于服务架构进行升级(单体架构、集群架构、微服务、SOA微服务)

新开发项目,建议直接以集群架构形式撸代码,不需要一开始就搭建微服务等,可根据业务需求实际出发。(不限于有SOA共享中心的伙伴)

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:SpringBoot 增强库 yue-library 更新,你们要的 JDK8 版本来了
加载中

最新评论(8

z
zb21863196
楼上都十三了😆
小小行者
小小行者
支持一波
hoofungson
hoofungson
哦,官方演示站都不能访问了。
yl-yue
yl-yue
能访问的,这是基于gitee构建的官网,应该是网络延迟的原因,等一会或多访问几次应该就可以了。感谢支持!
马脚
马脚
👍
hoofungson
hoofungson
要是能截图肯定给你截图看下,确实不能访问https://ylyue.cn/
yl-yue
yl-yue
可能是你的网络环境存在DNS解析问题,可以加入QQ群实时反馈:883630899。经过测试与询问,暂未发现官网有任何问题。你也可以测试下在手机上访问是否正常
yl-yue
yl-yue
欢迎留言...
返回顶部
顶部