PHP 终止5.2的更新,建议升级到5.3

小编辑
 小编辑
发布于 2010年08月01日
收藏 2

昨日,在php官网上php5.2.x系列稳定版更新到php5.2.14,PHP5.3.x系列更新到PHP5.3.3。同时这个版本主要改进了PHP5.2.x系列的稳定性,修复60多个BUG,部分BUG与安全相关。这个版本标志着对PHP5.2系列更新的结束,在此版本之后不再积极更新PHP5.2x,其安全补丁可能以单个形式发布。

与此同时,PHP开发团队发布了PHP5.3.3,修复了近100个BUG,鼓励所有PHP5.2系列的用户升级到PHP5.3。 但是实际上国内很多PHP程序对PHP5.3的支持都有不少小问题。

此外,PHP官网着重列出一个PHP5.3.3新的不兼容特性:在命名空间里,和类名一致的函数不再被作为一个构造函数。不过没有使用namespace的类不受影响。

 

下载:PHP5.3

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:PHP 终止5.2的更新,建议升级到5.3
加载中

最新评论(4

ValueError
ValueError

引用来自“钛元素”的评论

诸位,php5.3中没有ISAPI,我都是复制5.2的来用的,怎办?
难道一定要改成FastCGI?

FastCGI不用线程安全检查,性能不是更好吗?
ValueError
ValueError
好消息
钛元素
钛元素
诸位,php5.3中没有ISAPI,我都是复制5.2的来用的,怎办?
难道一定要改成FastCGI?
返回顶部
顶部