Rust 1.34.2 发布,安全漏洞补丁

clouddyy
 clouddyy
发布于 2019年05月16日
收藏 2

Rust 1.34.2 发布了,该版本主要修复了 Sean McArthur 报告的一个 安全漏洞 ,该漏洞影响标准库导致的 Error::downcast 系列方法执行静默类型转换时导致的数据越界的安全问题(CVE-2019-12083)。详细信息请看官方公告。 

Rust 是 Mozilla 的一个新的编程语言,由web语言的领军人物Brendan Eich(js之父),Dave Herman以及Mozilla公司的Graydon Hoare 合力开发。

 

创建这个新语言的目的是为了解决一个很顽疾的问题:软件的演进速度大大低于硬件的演进,软件在语言级别上无法真正利用多核计算带来的性能提升。Rust是针对多核体系提出的语言,并且吸收一些其他动态语言的重要特性,比如不需要管理内存,比如不会出现Null指针等等。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Rust 1.34.2 发布,安全漏洞补丁
加载中

最新评论(5

clouddyy
clouddyy

引用来自“rz”的评论

好麻烦,还依赖VC++,还下载不下来

引用来自“clouddyy”的评论

用二进制包嘛,还是你要自己编译

引用来自“rz”的评论

就是二进制包啊,只给了个在线安装器,然而还老是超时
科学上网
rz
rz

引用来自“rz”的评论

好麻烦,还依赖VC++,还下载不下来

引用来自“clouddyy”的评论

用二进制包嘛,还是你要自己编译
就是二进制包啊,只给了个在线安装器,然而还老是超时
clouddyy
clouddyy

引用来自“rz”的评论

好麻烦,还依赖VC++,还下载不下来
用二进制包嘛,还是你要自己编译
rz
rz
好麻烦,还依赖VC++,还下载不下来
唐代de豆腐
唐代de豆腐
没用过
返回顶部
顶部