jQuery 3.4.1 发布,修复上个版本的问题

局长
 局长
发布于 2019年05月05日
收藏 3

三周前,jQuery 发布了 3.4.0 版本,用户对这个版本反馈了不少问题,于是便有了这个修复问题的补丁版本 3.4.1。

1.在 IE 中触发获取或失去焦点的事件出现异常

在 jQuery 3.4.0 中,触发本地事件的事件处理程序带来了一些改变,例如focusblur。而这些变化导致了一个回归问题,有时会导致抛出神秘的错误"saved.shift is not a function",目前已修复。

示例代码

// Error thrown in IE10-11
// after clicking #test-element twice
jQuery("#test-element").click(function() {
  jQuery(this).trigger("blur");
});

2.修复在 iOS 10.0-10.2 中无法检查元素附件的问题

3.使用 AMD 加载 jQuery 出错的问题已修复

下载地址:

https://code.jquery.com/jquery-3.4.1.js
https://code.jquery.com/jquery-3.4.1.min.js

或者从 npm 获取该版本:

npm install jquery@3.4.1

GitHub changelog: Issues fixed in 3.4.1 | All changes

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:jQuery 3.4.1 发布,修复上个版本的问题
加载中

精彩评论

陈少鑫
陈少鑫
jQuery在我这里,还能再战5年以上。
布衣君
布衣君
老兵不朽
eechen
eechen

引用来自“恒久地平线”的评论

用原生API代替jQuery,https://github.com/nefe/You-Dont-Need-jQuery/blob/master/README.zh-CN.md
一通比较下来,jQuery明显更加简洁.
这篇反jQuery的比较简直成了jQuery的推广文.
有点讽刺了.
你们都是技术宅
你们都是技术宅
只要直接操作DOM的需求还存在一天,jQuery就会存在一天

最新评论(10

eechen
eechen

引用来自“恒久地平线”的评论

用原生API代替jQuery,https://github.com/nefe/You-Dont-Need-jQuery/blob/master/README.zh-CN.md
一通比较下来,jQuery明显更加简洁.
这篇反jQuery的比较简直成了jQuery的推广文.
有点讽刺了.
沙发迪
沙发迪

引用来自“陈少鑫”的评论

jQuery在我这里,还能再战5年以上。
8年
你们都是技术宅
你们都是技术宅
只要直接操作DOM的需求还存在一天,jQuery就会存在一天
红白机
红白机
一开始就用到现在
水木易安
水木易安

引用来自“日理万姬”的评论

jquery加入vue功能就好了
两者目标不同,jQuery的目的是为了抹平浏览器之间的bom差异,Vue是一个应用构建方式
莫默磨墨先生
莫默磨墨先生
每一位不会 jQuery 的前端都是假前端
陈少鑫
陈少鑫
jQuery在我这里,还能再战5年以上。
日理万姬
日理万姬
jquery加入vue功能就好了
布衣君
布衣君
老兵不朽
返回顶部
顶部