Spring Boot 2.1.3 发布,70 余项更新内容

h4cd
 h4cd
发布于 2019年02月16日
收藏 17

Spring Boot 2.1.3 发布了,此版本包括 70 多个 bug 修复、功能改进和依赖项升级。

可以从 Maven 中心与 https://repo.spring.io/release 下载。

如果仍在使用 Spring Boot 2.0.x,则强烈建议升级到 Spring Boot 2.1.x。值得注意的是,此前官方表示 Spring Framework 5.0.x 将于 3 月份 EOL,Spring Boot 2.0.x 也计划于 3 月底推出的最终版本中效仿,Spring Boot 1.5.x 将继续维护,直到 8 月份 EOL。

详细更新内容见更新日志

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Spring Boot 2.1.3 发布,70 余项更新内容
加载中

精彩评论

KevinBlandy
KevinBlandy
https://springboot.io 立即更新,跟上脚步 😁
MGL_TECH
MGL_TECH
立即 马上升级 一定要跟上脚步 不然时间久了 想跟新都难了

最新评论(19

ltlwill
ltlwill
升级到Spring Boot2.1.3后,添加spring-boot-devtools依赖做热部署会出现启动失败:

***************************
APPLICATION FAILED TO START
***************************

Description:

Failed to bind properties under 'server.error.include-stacktrace' to org.springframework.boot.autoconfigure.web.ErrorProperties$IncludeStacktrace:

Property: server.error.include-stacktrace
Value: ALWAYS
Origin: "server.error.include-stacktrace" from property source "devtools"
Reason: 0

Action:

Update your application's configuration
去掉此依赖就好了,有知道解决办法的吗?
izee
izee
end of lifecycle,产品生命周期结束,通俗来讲就是不再维护了
KevinBlandy
KevinBlandy

引用来自“Skqing”的评论

升级报错:Exception in thread "main" java.lang.AbstractMethodError: org.springframework.boot.context.config.ConfigFileApplicationListener.supportsSourceType(Ljava/lang/Class;)Z
  at org.springframework.context.event.GenericApplicationListenerAdapter.supportsSourceType(GenericApplicationListenerAdapter.java:81)
  at org.springframework.context.event.AbstractApplicationEventMulticaster.supportsEvent(AbstractApplicationEventMulticaster.java:295)
  at org.springframework.context.event.AbstractApplicationEventMulticaster.retrieveApplicationListeners(AbstractApplicationEventMulticaster.java:225)
  at org.springframework.context.event.AbstractApplicationEventMulticaster.getApplicationListeners(AbstractApplicationEventMulticaster.java:196)
  at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:133)
  at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:127)
  at o
这是新增了一个抽象方法你没实现么??也有可能是在实现类里面,使用了 super() 调用到了父类的抽象方法。
Skqing
Skqing
升级报错:Exception in thread "main" java.lang.AbstractMethodError: org.springframework.boot.context.config.ConfigFileApplicationListener.supportsSourceType(Ljava/lang/Class;)Z
  at org.springframework.context.event.GenericApplicationListenerAdapter.supportsSourceType(GenericApplicationListenerAdapter.java:81)
  at org.springframework.context.event.AbstractApplicationEventMulticaster.supportsEvent(AbstractApplicationEventMulticaster.java:295)
  at org.springframework.context.event.AbstractApplicationEventMulticaster.retrieveApplicationListeners(AbstractApplicationEventMulticaster.java:225)
  at org.springframework.context.event.AbstractApplicationEventMulticaster.getApplicationListeners(AbstractApplicationEventMulticaster.java:196)
  at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:133)
  at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:127)
  at o
日理万姬
日理万姬
今天从2.0.7升级了,发现了以前的bug,可能是override新版本不支持了,好麻烦
MGL_TECH
MGL_TECH
立即 马上升级 一定要跟上脚步 不然时间久了 想跟新都难了
v
vs_sun

引用来自“Spring-JPA”的评论

EOL是什么?
项目停止
北漂的我
北漂的我
spring 5 还没有开始用就 结束生命周期了😓
binbingin
binbingin

引用来自“shifeng1983”的评论

做了十多年java得东西,也是越来越痈肿了,有点审美疲劳了
现在是starter不是挺轻量了
lifes77
lifes77
还是原生servlet好,太臃肿不好
返回顶部
顶部