Apache Log4j 2.11.2 发布,流行的 Java 日志组件

来源: OSCHINA
编辑: 局长
2019-02-12

Apache Log4j 2.11.2 已发布,可用于生产环境。Log4j 2.11.2 是 Log4j 的最新版本,包含在 Log4j 2.6 发布后发现的几个错误修复,可以在最新的变更日志中找到修复内容列表。

要注意的是,Log4j 2 的 API 与 Log4j 1.x 不兼容,但是可以使用适配器来让应用程序继续使用 Log4j 1.x API。适配器也可用于 Apache Commons Logging, SLF4J 和 java.util.logging。

此外,在 Log4j 2.6 发布之后,由于向 Logger 接口添加了新方法,因此与先前版本出现不兼容问题。 如果你有以下代码:

logger.error(null, "This is the log message", throwable);

或类似于的任何日志级别,将会收到编译器错误,指出引用不明确。要纠正这个错误,要么:

logger.error("This is the log message", throwable);

要么

logger.error((Marker) null, "This is the log message", throwable);

Log4j 2.11.2 与之前的版本保持二进制兼容性,下载地址 https://logging.apache.org/log4j/2.x/download.html

2.11.2 的详细更新内容请查看发布说明

展开阅读全文
2 收藏
分享
加载中
精彩评论
换用logback的飘过
2019-02-12 09:28
3
举报
最新评论 (3)
不应该是曾经流行么
2019-02-12 17:03
0
回复
举报
老是不兼容,逼着我都要自己写日志组件了
2019-02-12 09:54
0
回复
举报
换用logback的飘过
2019-02-12 09:28
3
回复
举报
更多评论
3 评论
2 收藏
分享
返回顶部
顶部