小程序开发框架 Okam 发布 0.4.9,快应用正式支持

s
 sparkleMan
发布于 2019年01月16日
收藏 60

小程序开发框架 Okam(奥卡姆) 0.4.9 发布,目前 Okam 已经全面支持 百度/微信/支付宝/头条/快应用 开发,提供类 Vue 开发体验。未来,我们将进一步提供 H5 支持,以及完善各个平台的组件/API 对齐。具体主要更新内容如下:

  • 完善快应用的功能支持,包括 watch deep 支持等

  • 对于 百度小程序 不支持 for key 属性配置,不再打印 warning 信息,同时 key 属性也会保留不会删除 

  • 增加模板和CSS资源依赖分析,同时重构原生组件模板依赖分析,新增构建配置 component.template.resourceTags用于定制模板依赖资源分析 

  • px2rpx postcss 插件新增 ignore 选项,用于配置不想 px 转换的样式文件,默认 node_modules 下样式文件都不会转换 

  • CLI 工具支持 快应用

具体更新内容,请查看变更日志

各个平台支持情况,可以 参考文档。多平台代码支持的代码示例,可以参考 这个示例(该示例还待完善),由于快应用目前还没有正式线上例子,希望有快应用支持需求的开发者踩坑,有任何问题欢迎 提Issue

如果你有任何线上小程序使用了 Okam 框架,也欢迎通过 该Issue 反馈给我们,后续也会在我们项目首页进行展示。最后,如果你正在使用 Okam 或者其他小程序框架,希望可以帮忙完成一份简单的问卷调查,有助于我们后续更好完善小程序开发调查,问卷调查地址 点这里

 

如果对我们开源项目感兴趣,欢迎关注使用,也非常希望多多反馈问题和建议。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:小程序开发框架 Okam 发布 0.4.9,快应用正式支持
加载中

最新评论(4

龙影
龙影
厉害了
s
sparkleMan

引用来自“hehaheha”的评论

能支持html富文本处理吗
目前框架还不支持,需要开发者自行实现或者参考使用开源实现方案
hehaheha
hehaheha
能支持html富文本处理吗
x
xhong8023
开发了一款自研项目支持:一套代码,同时适配 百度,微信,已上线:https://github.com/ecomfe/okam/issues/29
返回顶部
顶部