guns-lite 升级 Spring Boot 到 2.1.1 版本

enilu
 enilu
发布于 2019年01月14日
收藏 7

guns-lite使用的Spring Boot从1.5.1升级到2.1.1

下面为升级过程

  • 版本升级

    <spring.boot.version>2.1.1.RELEASE</spring.boot.version>
    <springframework.version>5.1.3.RELEASE<springframework.version>
  • 配置增加

    spring.main.allow-bean-definition-overriding=true
    spring.jpa.hibernate.use-new-id-generator-mappings=false
  • 审计功能调整,调整后代码:

    @Configuration
    public class UserIDAuditorConfig implements AuditorAware<Long> {
        @Override
        public Optional<Long> getCurrentAuditor() {
            ShiroUser shiroUser = ShiroKit.getUser();
            if(shiroUser!=null){
                return Optional.of(shiroUser.getId());
            }
            return null;
        }
    }
  • repository调整

    • 之前的 delete(Long id)方法没有了,替换为:deleteById(Long id)

    • 之前的 T findOne(Long id)方法没有了,替换为:

      Optional<T> optional = ***Repository.findById(id);
             if (optional.isPresent()) {
                 return optional.get();
             }
             return null;
  • 随着这次Spring Boot的升级也顺便做了一些其他内容的调整和重构

    • springframework也从4.3.5.RELEASE升级到5.1.3.RELEASE

    • 为减小复杂度service去掉接口和实现类的结构,基础功能的service直接使用实现类;当然具体业务中如果有需求你也可以这没用

    • 去掉了一些暂时用不到的maven依赖

    • 完善了基础功能的审计功能(之前有介绍审计功能的实现翻番,后续会专门发一篇文档来说明审计功能在系统总的具体用法,当然聪明的你看代码就知道了)

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:guns-lite 升级 Spring Boot 到 2.1.1 版本
加载中
返回顶部
顶部