IntelliJ IDEA 2018.3.3 发布,针对 JDK 12 的改进

段段段落
 段段段落
发布于 2019年01月11日
收藏 5

IntelliJ IDEA 2018.3.3 发布,一个新的 Bug 修复版本。建议您更新到最新版。

你可能已经知道,从 JDK 12 开始,原始字符串文字(Raw String Literals (JEP 326))特性已经是内置的,这是我们改变在 IntelliJ IDEA 支持它的原因。已有的 Java 12 项目将自动迁移到最新的 Java, Java 11 的发行版本。如果你仍要在 IDE 支持原始字符串文字,请把项目语言等级(Project Language Level)设置成 ”X- Experimental features“。

其他的更新主要是:

  • 捆绑的 Kotlin 插件更新到 1.3.11版本!

  • IDE 现在和 Maven 3.6.0 正常工作: IDEA-201282

  • 多个针对 Groovy 的 Bug 修复: IDEA-203850, IDEA-203569, IDEA-203767, IDEA-201294

  • Thymeleaf 插件的性能改进:IDEA-202588

  • 在服务器(task server)开启了“Add commit message”选项后,取消提交,内容不再会遗失:IDEA-173186

  • 现在 JavaEE 服务器运行配置的重运行操作,会引起更新操作:IDEA-203047

  • 修复 SVN Commit 日记在出现前会挂一长段时间:IDEA-202942

  • 现在 IDE 可以接收所有的远程操作:IDEA-201193

下载地址:https://www.jetbrains.com/idea/download/

新闻出处:https://blog.jetbrains.com/idea/2019/01/intellij-idea-2018-3-3-is-released

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:IntelliJ IDEA 2018.3.3 发布,针对 JDK 12 的改进
加载中

精彩评论

红薯
红薯
我用 JDK 8
平安OSC
平安OSC
我用Kotlin
你个大胖子
你个大胖子
我用J8
zqq90
zqq90

引用来自“犀利疯子”的评论

我用1.4,1.6,1.7,1.8:neckbeard:😈
大家都在秀优越感,就你在比惨
Credo-Zhao
Credo-Zhao
我用 JDK 8

最新评论(23

miniy
miniy
vue 插件不兼容了 坑爹了 怎么回退版本
二进制艺术
二进制艺术
只用 Java 最新版
純白陰影
純白陰影
我用J8
Yoona520
Yoona520
IDEA不要用最新的,最感觉有一些不知名的问题,老版的基本没太大问题
ldl123292
ldl123292
用这个版本自动提示非常卡,有切回到2.7了
kut
kut

引用来自“红薯”的评论

我用 JDK 8
嗯,还是jdk8靠谱。
很拽De土豆
很拽De土豆

引用来自“grath”的评论

JDK 11

引用来自“FogMoon”的评论

jdk11 maven compiler报找不到tools.jar怎么解决
百度一下有很多方法的
grath
grath

引用来自“grath”的评论

JDK 11

引用来自“FogMoon”的评论

jdk11 maven compiler报找不到tools.jar怎么解决
我是在Linux平台 openjdk 没遇到啥问题呢
FogMoon
FogMoon

引用来自“grath”的评论

JDK 11
jdk11 maven compiler报找不到tools.jar怎么解决
你个大胖子
你个大胖子
我用J8
返回顶部
顶部