PHP 5.6 已结束安全支持,你升级到 PHP 7 系列了吗?

王练
 王练
发布于 2019年01月06日
收藏 8

PHP 官网近日更新了版本支持列表,自2019年1月1日起,PHP 5.6 已不再受官方支持,使用 PHP 5.6 版本的网站将不再收到安全漏洞或错误更新。此外,PHP 7.0 也已于2018年12月1日结束安全支持。

官方当前提供支持的有3个版本:PHP 7.1 、7.2 和 7.3 。PHP 7.1 发布于2016年12月1日,即将于今年12月结束支持,建议用户往更新的 7.2 和 7.3 版本迁移。

根据 W3Techs 最新统计数据,其研究的网站样本中使用的 PHP 的比例高达 78.9%,在这些网站中使用 PHP 5 的比例高达 74.1% ,远高于 PHP 7 系列。这也意味着目前有大量的网站其实是存在安全隐患的。

你目前使用的是哪个版本?最近是否有升级计划呢?欢迎评论。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:PHP 5.6 已结束安全支持,你升级到 PHP 7 系列了吗?
加载中

精彩评论

这波天秀
这波天秀

引用来自“科技范麒麟才子”的评论

已告别 php
井蛙er别装了,井蛙er是不是有那种冒充的习惯?
cisiqo
cisiqo

引用来自“太懒”的评论

我旧项目用的好好的,为毛要升
我们的项目之前用的php5.5,被国家网安总队扫描了,强制要求我们升级
全体人员
全体人员
已经转投node-ts阵营。
科技范麒麟才子
科技范麒麟才子
已告别 php
梅开源
梅开源
很多linux预装php5,所以这么多。

最新评论(20

MuskIron
MuskIron
现在用7.2,等到7.3有5个迭代版本就升级7.3。不要盲目升级新版本,坑多问题多,几个版本迭代之后大问题就不会有了
小卡车呼呼呼
新项目全部都是基于7.3了
梅开源
梅开源
很多linux预装php5,所以这么多。
cisiqo
cisiqo

引用来自“太懒”的评论

我旧项目用的好好的,为毛要升
我们的项目之前用的php5.5,被国家网安总队扫描了,强制要求我们升级
栓独爱青春
栓独爱青春
用的都是5.6
全体人员
全体人员
已经转投node-ts阵营。
bkkkd
bkkkd
准备升了。开发环境早已经升级到7了
冰力
冰力

引用来自“冰力”的评论

除了外包公司都升级到 php 7.x 了吧?

引用来自“自由PHP”的评论

没,用的一些老系统,才刚从5.3逐步升级到5.6
@自由PHP 老系统比较困难,5.3 升级 5.6 和没升级差不多了,7.3 之后应该稳定了, 7.0 7.1 7.2 都有些不兼容。
太懒
太懒
我旧项目用的好好的,为毛要升
cisiqo
cisiqo
网安要是不管,我们才懒得升级
返回顶部
顶部