Qt for Python 5.12 发布 ,没有 LTS 支持的版本

程六金
 程六金
发布于 2018年12月21日
收藏 4

Qt for Python 5.12发布,你可以通过以下方式安装该版本:

pip install PySide2

此外,您可以从 Qt 的官方下载服务器下载软件,或者从我们的Git存储库获取源代码。

请注意,Qt for Python与特定的 Qt 版本紧密绑定,但不会继承 Qt 5.12 中的 LTS(三年支持)标志。这意味着此版本从发布日开始支持一年。我们的未来目标是在 Qt for Python 基于的 Qt 版本的同时发布 Qt for Python。但是现在并没有做到这一点

PySide2 和 Shiboken2

该版本包含两个模块。第一个模块是PySide2为大多数 Qt API 提供 Python 包装器,第二个模块是Shiboken2允许用户包装自己的 C ++ 库并使它们可用于 Python。在软件内部,PySide2 模块依赖于 Shiboken。

删除技术预览(TP)标签意味着一定的兼容性保证。和 C ++ 的兼容性相比,此兼容性声明对于 Python 用户的 Qt 有所不同。它主要依赖于 Qt 的源兼容性保证,因为我们使用特定的语法来公开 Qt的 C ++ API。用 Qt for Python 5.12 编写的任何 Python 应用程序兼容于未来的新版本。在 Shiboken 方面,我们继续持有 TP 标签。

Qt for Python 5.12目前支持在**Python 2.7和3.5+**环境下运行。

了解更多请查看发行说明

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Qt for Python 5.12 发布 ,没有 LTS 支持的版本
加载中

最新评论(3

冰力
冰力
还提供 2.7 艹,把 3.5+ 玩儿明白就不错了
y
yh2216
棒棒的
小果汁儿
小果汁儿
兼容性好
返回顶部
顶部