Clojure 1.10 发布,改进 Java 兼容性

行者__
 行者__
发布于 2018年12月20日
收藏 5

经过近一年的开发,Clojure 1.10 正式发布了。

Clojure 1.10 主要聚焦于两个方面:改进错误报告和 Java 兼容性。

现在,REPL 处的错误报告会根据执行阶段(读取、宏扩展、编译等)对错误进行分类,错误还将附带所在位置和上下文等附加信息。此功能内置于 clojure.main REPL 中,但也可用于其他 REPL 和工具,能够通过修饰数据以生成更好的错误消息。

Clojure 1.10 要求 Java 8 及以上版本,并已针对与 Java 8 和 Java 11 的兼容性进行了更新。更改包括与字节码相关的错误修复,删除了已弃用的 API 以及与 Java 9 中引入的模块系统相关的更新。

有关 Clojure 1.10 中所有修复、改进和新特性,请参阅更改日志

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Clojure 1.10 发布,改进 Java 兼容性
加载中

精彩评论

s
shifeng1983

引用来自“邪小白”的评论

特别喜欢这个语言,我是因为storm才学了它。而且非常喜欢用它来写一些私单。不过感觉越来越势微。可能是因为没有杀手级应用吧。
)))))))))))))
二的基本算合格
二的基本算合格
特别喜欢Clojure,可惜就像很多人说的,缺少杀手级应用~

最新评论(8

邪小白
邪小白

引用来自“邪小白”的评论

特别喜欢这个语言,我是因为storm才学了它。而且非常喜欢用它来写一些私单。不过感觉越来越势微。可能是因为没有杀手级应用吧。

引用来自“shifeng1983”的评论

)))))))))))))
别这样嘛,每个语言都有个把特色嘛。比如,npm的module黑洞,比如java的继承、组合的层次链。多多少少的。
邪小白
邪小白

引用来自“邪小白”的评论

特别喜欢这个语言,我是因为storm才学了它。而且非常喜欢用它来写一些私单。不过感觉越来越势微。可能是因为没有杀手级应用吧。

引用来自“超级大黑猫”的评论

请问这个语言做web程序好用吗?
一般用什么框架?
我经常用luminus的,如果你觉得这个太范式,你可以用用其他的ring系列的,比如duck,或者你直接查clojure-tool网站,awesome-clojure也可以的,很多web的框架。其实用它处理数据是最好的,web可能有点不是很舒服。
我没有抓狂
我没有抓狂
lisp 牛逼
二进制艺术
二进制艺术
这个太难了
二的基本算合格
二的基本算合格
特别喜欢Clojure,可惜就像很多人说的,缺少杀手级应用~
国产大熊猫
国产大熊猫

引用来自“邪小白”的评论

特别喜欢这个语言,我是因为storm才学了它。而且非常喜欢用它来写一些私单。不过感觉越来越势微。可能是因为没有杀手级应用吧。
请问这个语言做web程序好用吗?
一般用什么框架?
s
shifeng1983

引用来自“邪小白”的评论

特别喜欢这个语言,我是因为storm才学了它。而且非常喜欢用它来写一些私单。不过感觉越来越势微。可能是因为没有杀手级应用吧。
)))))))))))))
邪小白
邪小白
特别喜欢这个语言,我是因为storm才学了它。而且非常喜欢用它来写一些私单。不过感觉越来越势微。可能是因为没有杀手级应用吧。
返回顶部
顶部