Yarn v1.12.1 发布,Facebook 的 JavaScript 包管理器

来源: OSCHINA
编辑: 局长
2018-10-25

Yarn v1.12.1 发布了,这是一个 Facebook 推出的 JavaScript 包管理器。该版本主要是修复了 bug,但也包括功能改进和新增功能,具体如下

  • Ensures the engine check is ran before showing the UI for upgrade-interactive #6536 - Orta Therox

  • Restores Node v4 support by downgrading cli-table3 #6535 - Mark Stacey

  • Prevents infinite loop when parsing corrupted lockfiles with unterminated strings #4965 - Ryan Hendrickson

  • Environment variables now have to start with YARN_ (instead of just contain it) to be considered #6518 - Michael Gmelin

  • Fixes the extensions option when used by resolveRequest #6479 - Maël Nison

  • Fixes handling of empty string entries for bin in package.json #6515 - Ryan Burrows

  • Adds support for basic auth for registries with paths, such as artifactory #5322 - Karolis Narkevicius

  • Adds 2FA (Two Factor Authentication) support to publish & alike #6555 - Krzysztof Zbudniewek

  • Fixes how the files property is interpreted to bring it in line with npm #6562 - Bertrand Marron

  • Fixes Yarn invocations on Darwin when the yarn binary was symlinked #6568 - Hidde Boomsma

  • Fixes require.resolve when used together with the paths option #6565 - Maël Nison

Yarn 是 Facebook 推出的 JavaScript 包管理器,旨在提供 npm 之外的另一种选择方案。Yarn 具有极佳的伸缩性,可以支持成千上万个直接或间接的包依赖。Yarn 的设计初衷是保证稳定性、弹性和高性能。

那么 Yarn 和 npm 有什么不同呢?两者最大的不同在于安装包的方式,Yarn 用到了 lockfiles 和确定性算法。Lockfile 会把安装的包版本进行锁定,保证了 node_modules 目录在不同设备上的安装结果是一致的,同时支持并行操作,大大加快安装进程。此外,Yarn 还声明同时兼容 npm 和 Bower,支持两个仓库混合使用,同时支持包的离线安装(只要你曾经安装过这个包)。

Yarn 1.0 的发布时间是 2017 年 9 月,可点此查看更新内容。

Yarn 1.12.1 源码下载 https://github.com/yarnpkg/yarn/releases/tag/v1.12.1

展开阅读全文
1 收藏
分享
加载中
最新评论 (2)

引用来自“这波天秀”的评论

基本就是废的东西,包管理器竟然不统一,东一个西一个,注定就是玩具
java的包管理器不是更多。。。
2018-10-26 10:57
0
回复
举报
基本就是废的东西,包管理器竟然不统一,东一个西一个,注定就是玩具
2018-10-25 18:25
0
回复
举报
更多评论
2 评论
1 收藏
分享
返回顶部
顶部