GuzzleSwoole v1.1.0,让 Guzzle 完美兼容 Swoole 协程

宇润
 宇润
发布于 2018年09月17日
收藏 6

让 Guzzle 支持 Swoole 协程,这个项目目的就是这么简单明了!

本项目不包含 Guzzle 功能,请自行在项目中引用 Guzzle 6.x,理论上可以支持升级 Guzzle 版本而无需更新 Guzzle-Swoole!

Composer:"yurunsoft/guzzle-swoole":"~1.1"

v1.1.0 版本说明:

说明

众所周知,使用 Guzzle 指定 Handler,需要在实例化 Client 时传入。

这样一来,想要把基于 Guzzle 开发的 SDK 用于 Swoole 协程环境就需要对原有 SDK 代码进行修改。

Guzzle-Swoole 这个项目目前已经实现无需修改任何代码,只需一句话设置全局默认处理器,完美无缝兼容 Swoole 协程环境。

使用

在 Swoole >= 4.2.0 中,你可以把默认 Handler 设为 StreamHandler。

\GuzzleHttp\DefaultHandler::setDefaultHandler(\Yurun\Util\Swoole\Guzzle\SwooleHandler::class);

在 Swoole < 4.2.0 中,你可以把默认 Handler 设为本项目实现的 SwooleHandler。

\GuzzleHttp\DefaultHandler::setDefaultHandler(\GuzzleHttp\Handler\StreamHandler::class);

这样一来,实现完美无缝兼容~

实现原理

首先依赖了funkjedi/composer-include-files这个项目,这个项目的功能是把composer.json中配置引入的文件优先引入,这样就可以在这个文件里进行提前处理

接着通过 Composer 插件机制,在post-autoload-dump事件中做处理。

读取guzzlehttp/guzzle/src/functions.php文件,将choose_handler()方法定义从代码中去除,把修改后内存保存为guzzle-swoole/src/load.php文件。

guzzle-swoole/src/functions.php文件中定义了修改后的choose_handler()方法,用于实现全局默认处理器的设置和获取。

load.phpfunctions.php两个文件会在运行时优先引入,然后根据guzzlehttp/guzzle/src/functions_include.php中写的判断,Guzzle 就不会再引入他原有的functions.php文件了。

代码仓库

码云:https://gitee.com/yurunsoft/Guzzle-Swoole

Github:https://github.com/Yurunsoft/Guzzle-Swoole

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:GuzzleSwoole v1.1.0,让 Guzzle 完美兼容 Swoole 协程
加载中

精彩评论

长宁楚王陈涉
长宁楚王陈涉
手动点赞。很好。

最新评论(4

纵度飞行
纵度飞行
支持下
Fyinc
Fyinc
大佬呀 , 经常看你在swoft里面:relaxed:
李永波
李永波
漂亮
长宁楚王陈涉
长宁楚王陈涉
手动点赞。很好。
返回顶部
顶部