BeetlSQL 2.9.11 发布,Java Dao 工具 - 开源中国社区
BeetlSQL 2.9.11 发布,Java Dao 工具
闲大赋 2017年10月27日

BeetlSQL 2.9.11 发布,Java Dao 工具

闲大赋 闲大赋 发布于2017年10月27日 收藏 28

有免费的MySQL,为什么还要买? >>>  

BeetlSQL 2.9.11 发布了,做了微小改进:

#IFDJ4 实现Dao Mapper的toString方法,以避免IDE调试的时候查看此Mapper报错

<dependency>
    <groupId>com.ibeetl</groupId>
    <artifactId>beetlsql</artifactId>
    <version>2.9.11</version>
</dependency>

如果使用Spring Boot,可以使用Starter

<dependency>
    <groupId>com.ibeetl</groupId>
    <artifactId>beetl-framework-starter</artifactId>
    <version>1.1.16.RELEASE</version>
</dependency>

BeetlSql 是全新的Java 数据库访问 工具,具有如下特性:

开发效率:
1 无需注解,自动使用大量内置SQL,轻易完成增删改查功能,节省50%的开发工作量
2 数据模型支持Pojo,也支持Map/List这种快速模型,也支持混合模型
3 SQL 模板基于Beetl实现,更容易写和调试,以及扩展
4 代码生成pojo类和sql模版,可以针对单个表(或者视图),甚至是整个数据库。能减少代码编写工作量

维护性:
5 SQL 以更简洁的方式,Markdown方式集中管理,同时方便程序开发和数据库SQL调试。
可以自动将sql文件映射为dao接口类
6 直观灵活的支持一对一,一对多,多对多关系映射而不引入复杂的OR Mapping概念和技术。
7 具备Interceptor功能,可以调试,性能诊断SQL,以及扩展其他功能。
8 支持各种数据库,真正的跨数据库平台

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:BeetlSQL 2.9.11 发布,Java Dao 工具
分享
评论(17)
精彩评论
1

引用来自“KELLS”的评论

最新发的2.9.11版本有个bug,初始化bug,找不到org.beetl.core.ResourceLoader类,换到上一个版本2.8.6是正常运行的,到2.9.11运行就报找不到这个类。最新2.9.11的文档没有依赖beetl库,找不到这个类,最好在官网的文档上能够有说明一下 @闲大赋

引用来自“闲大赋”的评论

说明依赖的beetl没有下载下来原因吧?应该是maven下载jar的问题

引用来自“阿_嚏”的评论

我也遇到这个问题,又回退了
应该你用的是阿里云镜像吧,没来得及同步,你可以去掉镜像直接从中央仓库下载看看
最新评论
0

引用来自“KELLS”的评论

最新发的2.9.11版本有个bug,初始化bug,找不到org.beetl.core.ResourceLoader类,换到上一个版本2.8.6是正常运行的,到2.9.11运行就报找不到这个类。最新2.9.11的文档没有依赖beetl库,找不到这个类,最好在官网的文档上能够有说明一下 @闲大赋

引用来自“闲大赋”的评论

说明依赖的beetl没有下载下来原因吧?应该是maven下载jar的问题

引用来自“阿_嚏”的评论

我也遇到这个问题,又回退了

引用来自“闲大赋”的评论

应该你用的是阿里云镜像吧,没来得及同步,你可以去掉镜像直接从中央仓库下载看看
确实用的阿里云镜像:smile:
0

引用来自“大道至简氵”的评论

对储存过程的调用还是没有优化
没有,这个只是支持调用
1

引用来自“KELLS”的评论

最新发的2.9.11版本有个bug,初始化bug,找不到org.beetl.core.ResourceLoader类,换到上一个版本2.8.6是正常运行的,到2.9.11运行就报找不到这个类。最新2.9.11的文档没有依赖beetl库,找不到这个类,最好在官网的文档上能够有说明一下 @闲大赋

引用来自“闲大赋”的评论

说明依赖的beetl没有下载下来原因吧?应该是maven下载jar的问题

引用来自“阿_嚏”的评论

我也遇到这个问题,又回退了
应该你用的是阿里云镜像吧,没来得及同步,你可以去掉镜像直接从中央仓库下载看看
0

引用来自“KELLS”的评论

最新发的2.9.11版本有个bug,初始化bug,找不到org.beetl.core.ResourceLoader类,换到上一个版本2.8.6是正常运行的,到2.9.11运行就报找不到这个类。最新2.9.11的文档没有依赖beetl库,找不到这个类,最好在官网的文档上能够有说明一下 @闲大赋

引用来自“闲大赋”的评论

说明依赖的beetl没有下载下来原因吧?应该是maven下载jar的问题
我也遇到这个问题,又回退了
0
对储存过程的调用还是没有优化
0
支持
0

引用来自“KELLS”的评论

最新发的2.9.11版本有个bug,初始化bug,找不到org.beetl.core.ResourceLoader类,换到上一个版本2.8.6是正常运行的,到2.9.11运行就报找不到这个类。最新2.9.11的文档没有依赖beetl库,找不到这个类,最好在官网的文档上能够有说明一下 @闲大赋

引用来自“闲大赋”的评论

说明依赖的beetl没有下载下来原因吧?应该是maven下载jar的问题
居然还真是没下载下来,刚看到依赖文件是有的。我还以为是2.9.11给移除了beetl库的依赖呢
0

引用来自“KELLS”的评论

最新发的2.9.11版本有个bug,初始化bug,找不到org.beetl.core.ResourceLoader类,换到上一个版本2.8.6是正常运行的,到2.9.11运行就报找不到这个类。最新2.9.11的文档没有依赖beetl库,找不到这个类,最好在官网的文档上能够有说明一下 @闲大赋
说明依赖的beetl没有下载下来原因吧?应该是maven下载jar的问题
0
最新发的2.9.11版本有个bug,初始化bug,找不到org.beetl.core.ResourceLoader类,换到上一个版本2.8.6是正常运行的,到2.9.11运行就报找不到这个类。最新2.9.11的文档没有依赖beetl库,找不到这个类,最好在官网的文档上能够有说明一下 @闲大赋
0
支持
0

引用来自“潇洒的吸血鬼”的评论

内置的SQL不够强大,或者说对于有的项目。内置可以完成全部的开发工作。但是对于有的项目连百分之十都完成不了。内置的template就支持值相等比较。不支持多于少于,模糊查询,排序等等。而且代码生成工具太弱了。建议可以参考下mybatis的example

引用来自“闲大赋”的评论

JPA ExampleMatcher 类似功能正在规划中,目前还是以SQL为主。
:+1: cool,example不错
0

引用来自“阿_嚏”的评论

注解能与jpa兼容就更好了
有个JPA2NameConversion 能部分兼容
0

引用来自“潇洒的吸血鬼”的评论

内置的SQL不够强大,或者说对于有的项目。内置可以完成全部的开发工作。但是对于有的项目连百分之十都完成不了。内置的template就支持值相等比较。不支持多于少于,模糊查询,排序等等。而且代码生成工具太弱了。建议可以参考下mybatis的example
JPA ExampleMatcher 类似功能正在规划中,目前还是以SQL为主。
0
内置的SQL不够强大,或者说对于有的项目。内置可以完成全部的开发工作。但是对于有的项目连百分之十都完成不了。内置的template就支持值相等比较。不支持多于少于,模糊查询,排序等等。而且代码生成工具太弱了。建议可以参考下mybatis的example
0
注解能与jpa兼容就更好了
0
挺好使的
0
赞,一直在关注。
顶部