Spring Boot 2.0.0.M5 发布,初步支持 Java 9 - 开源中国社区
Spring Boot 2.0.0.M5 发布,初步支持 Java 9
淡漠悠然 2017年10月12日

Spring Boot 2.0.0.M5 发布,初步支持 Java 9

淡漠悠然 淡漠悠然 发布于2017年10月12日 收藏 8

免费体验IBM Cloud,构建Iot应用 >>>  

Spring Boot 2.0.0 M5已经发布,现在可以从里程碑存储库中获得。这个版本关闭了168个issue和PR。

值得关注的更新:

  • 初步支持 Java 9 —— Spring Boot 将继续改进对Java 9的支持,该版本应该适用于基本的应用程序。

  • 对来自 Spring Security OAuth 2.0 客户端的支持 —— 该版本为 Spring Security 的 OAauth 2.0 客户端提供了自动配置。

  • 支持 JSON-B —— 支持 JSON-B 和现有的 Jackson 和 Gson 集成。推荐 Jackson 作为默认的选择。

  • Session Actuator endpoint —— Spring Session 的用户现在可以直接从执行器查看会话。

有关更改和升级说明的完整列表,请参阅 WIKI 上的 Spring Boot 2.0.0.M5 发布说明

详情请参阅发布主页

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Spring Boot 2.0.0.M5 发布,初步支持 Java 9
分享
评论(19)
精彩评论
8

引用来自“beyondforever68”的评论

"采用了一种固执己见的观点"?
Spring Boot takes an opinionated view of building production-ready Spring applications。
这里的opinionated view不能被译为“固执己见的观点”。opinionated 表面意思是自以为是的,固执己见的,view这里应该是视角、观点之意。其实其本意是说Spring Boot有自己的一套构建标准和条件,你需要按照它定义的模式、方式去做。
一个软件被说成是 opinionated,意思就是它要求你按照它的意愿去做事。

具体可以见Stack Overflow上的“What is opinionated software?”疑问
https://stackoverflow.com/questions/802050/what-is-opinionated-software
1

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:
Spring Boot 的兼容性从来都不好。。。1.4, 1.5 之间变化少一点,配置基本上没问题。之前的版本每个版本很多 API变化, 1.3 到 1.4 的变化非常大,参见 https://hantsy.gitbooks.io/build-a-restful-app-with-spring-mvc-and-angularjs/content/boot-1.4.html。升级的时候发现很多类和包移动了。
2. 0 不用说了,自己看 Changlog 就知道了。
1

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:
@jasonwu24 现有代码改动不大,基本直接可以上2
1

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:
明显不兼容。 jdk版本就已经注定了
1
这翻译 也是真是的 直接 粘贴的?
最新评论
0

引用来自“puras”的评论

这个新闻有点晚哈。
上周就用了,已做完验证,需要修改的地方很少。

引用来自“局长”的评论

你看下发布日期,其实也是上周发的新闻,只不过昨天才把它置顶了~
呃,我瞎了。
0
今年年底能出正式版么
0

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:

引用来自“臭水沟”的评论

明显不兼容。 jdk版本就已经注定了
jdk的事情好办
0

引用来自“puras”的评论

这个新闻有点晚哈。
上周就用了,已做完验证,需要修改的地方很少。
你看下发布日期,其实也是上周发的新闻,只不过昨天才把它置顶了~
0

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:

引用来自“hantsy”的评论

Spring Boot 的兼容性从来都不好。。。1.4, 1.5 之间变化少一点,配置基本上没问题。之前的版本每个版本很多 API变化, 1.3 到 1.4 的变化非常大,参见 https://hantsy.gitbooks.io/build-a-restful-app-with-spring-mvc-and-angularjs/content/boot-1.4.html。升级的时候发现很多类和包移动了。
2. 0 不用说了,自己看 Changlog 就知道了。
一般用法变化并不大,只是有些高级定制变化大一点,但不影响整个项目,只是局部会改动
0
666
0
线上已经使用了。
0
这个新闻有点晚哈。
上周就用了,已做完验证,需要修改的地方很少。
0

引用来自“wyzcn”的评论

有啥新特性,跟 1.x 比起来,能不能给介绍下
spring5咯
0
spring本身的兼容性都有问题,更不用说spring-boot了……版本号第二位尽量保持一致,否则有些依赖包会变
1

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:
Spring Boot 的兼容性从来都不好。。。1.4, 1.5 之间变化少一点,配置基本上没问题。之前的版本每个版本很多 API变化, 1.3 到 1.4 的变化非常大,参见 https://hantsy.gitbooks.io/build-a-restful-app-with-spring-mvc-and-angularjs/content/boot-1.4.html。升级的时候发现很多类和包移动了。
2. 0 不用说了,自己看 Changlog 就知道了。
1

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:
@jasonwu24 现有代码改动不大,基本直接可以上2
1

引用来自“jasonwu24”的评论

不知道Spring Boot 2会不会不兼容1?!:alien:
明显不兼容。 jdk版本就已经注定了
1
这翻译 也是真是的 直接 粘贴的?
0
上github看一眼,之前说好的11月底RELEASE已经变成11月底RC1了…
丢人啊,摸了
8

引用来自“beyondforever68”的评论

"采用了一种固执己见的观点"?
Spring Boot takes an opinionated view of building production-ready Spring applications。
这里的opinionated view不能被译为“固执己见的观点”。opinionated 表面意思是自以为是的,固执己见的,view这里应该是视角、观点之意。其实其本意是说Spring Boot有自己的一套构建标准和条件,你需要按照它定义的模式、方式去做。
一个软件被说成是 opinionated,意思就是它要求你按照它的意愿去做事。

具体可以见Stack Overflow上的“What is opinionated software?”疑问
https://stackoverflow.com/questions/802050/what-is-opinionated-software
0
不知道Spring Boot 2会不会不兼容1?!:alien:
0
"采用了一种固执己见的观点"?
0
有啥新特性,跟 1.x 比起来,能不能给介绍下
顶部