Apache Kylin v2.0.0 Beta 尝鲜版上线
王练 2017年02月28日

Apache Kylin v2.0.0 Beta 尝鲜版上线

王练 王练 发布于2017年02月28日 收藏 8 评论 11

开源中国全球专享福利,云栖大会购票大返现!>>>  

Apache Kylin 社区于日前宣布:Apache Kylin v2.0.0 Beta 版发布。

此次 Apache Kylin v2.0.0 Beta 升级的功能有:

  • (KYLIN-1875)支持雪花数据模型

  • (KYLIN-2467)支持TPC-H查询

  • (KYLIN-2331)Spark cubing引擎

  • (KYLIN-2006)工作引擎HA

  • (KYLIN-2396)百分位数的措施

  • (KYLIN-2351)云测试

注意:目前由于元数据不兼容,所以 Apache Kylin v2.0.0 Beta 暂时不能在 v1.6.0 上升级,需要一个新的安装环境,但是底层多维数据集是向后兼容的。Apache Kylin 技术团队正在开发一个升级工具来转换元数据,以便后续可以顺利升级。

Spark cubing 引擎

基于 Apache Spark,Apache Kylin v2.0.0 引入了一个新的 cubing 引擎,可以选择替换原来的 MR 引擎。初步测试表明:在大多数情况下,Spark 引擎可以将时间缩短到50%。

  • 在跑 Spark 引擎配置的时候需要在 kylin.properties 里设置好

  1. 确保 HADOOP_CONF_DIR 里包含:核心网站的 XML, Yarn, Hive 和 Hbase

  2. 根据您的环境去调试这些数据:Spark 的执行情况、cores 和内存

  3. Hive on Tez 并没有按照我们测试的期望的样子运行,具体原因不明,只能切换到 Hive on MR 去跑。

  • 创建新多维数据集时,需要在“高级设置”选项卡中选择“Spark 引擎”。

下载地址:

测试链接: 

http://kylin.apache.org/download/

 源代码:

 https://github.com/apache/kylin/tree/kylin-2.0.0-beta

运行 TPC-H 基准在 Apache Kylin 社区可以找到,请点击这里:

https://github.com/kyligence/kylin-tpch

稿源:apachekylin

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Apache Kylin v2.0.0 Beta 尝鲜版上线
分享
评论(11)
精彩评论
1
也可以openjdk 喽 ,或者自己写个jdk
1

引用来自“ak_birdofprey”的评论

还是需要建在OracleJDK上吗??!!!

引用来自“红薯”的评论

人家 Java 开发的,肯定是 JDK 啊
回复@红薯 : 呵呵一下:sweat_smile::sweat_smile::sweat_smile:
最新评论
0
......
0
test
0
开始支持spark是个不错的变化
0
hahah
0
现在大数据都用这个吗?
1
也可以openjdk 喽 ,或者自己写个jdk
0

引用来自“ak_birdofprey”的评论

还是需要建在OracleJDK上吗??!!!

引用来自“红薯”的评论

人家 Java 开发的,肯定是 JDK 啊

引用来自“ak_birdofprey”的评论

回复@红薯 : 呵呵一下:sweat_smile::sweat_smile::sweat_smile:

引用来自“红薯”的评论

阴阳怪气不好
回复@红薯 : 吃红薯补补啦:smile::smirk:
0

引用来自“ak_birdofprey”的评论

还是需要建在OracleJDK上吗??!!!

引用来自“红薯”的评论

人家 Java 开发的,肯定是 JDK 啊

引用来自“ak_birdofprey”的评论

回复@红薯 : 呵呵一下:sweat_smile::sweat_smile::sweat_smile:
阴阳怪气不好
1

引用来自“ak_birdofprey”的评论

还是需要建在OracleJDK上吗??!!!

引用来自“红薯”的评论

人家 Java 开发的,肯定是 JDK 啊
回复@红薯 : 呵呵一下:sweat_smile::sweat_smile::sweat_smile:
0

引用来自“ak_birdofprey”的评论

还是需要建在OracleJDK上吗??!!!
人家 Java 开发的,肯定是 JDK 啊
0
还是需要建在OracleJDK上吗??!!!

相关资讯
最新资讯
热门资讯
顶部