Apache Lucene 6.2.1,Java 搜索引擎工具包
淡漠悠然 2016年09月21日

Apache Lucene 6.2.1,Java 搜索引擎工具包

淡漠悠然 淡漠悠然 发布于2016年09月21日 收藏 16

开源中国全球专享福利,云栖大会购票大返现!>>>  

Apache Lucene 6.2.1 发布了,修复了上个版本的3个bug

改进内容:

  1. LUCENE-7417: The standard Highlighter could throw an IllegalArgumentException when trying to highlight a query containing a degenerate case of a MultiPhraseQuery with one term. 

  2. LUCENE-7440: Document id skipping (PostingsEnum.advance) could throw an ArrayIndexOutOfBoundsException exception on large index segments (>1.8B docs) with large skips. 

  3. LUCENE-7318: Fix backwards compatibility issues around StandardAnalyzer and its components, introduced with Lucene 6.2.0. The moved classes were restored in their original packages: LowercaseFilter and StopFilter, as well as several utility classes. 

点此查看完整更新内容发行主页

下载地址:


本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Apache Lucene 6.2.1,Java 搜索引擎工具包
分享
评论(6)
最新评论
0
版本这么高了
0
还在3.6。。。。
0

引用来自“小檀”的评论

这个标题会让人误解的,Lucene只是一个工具包:http://www.oschina.net/p/lucene
谢谢提醒,已修改 : )
0
这个标题会让人误解的,Lucene只是一个工具包:http://www.oschina.net/p/lucene
0
更新好快呀,我还在用4.6的版本
0
如何集成
顶部