OmniFaces 2.0 发布,JSF2 工具库 - 开源中国社区
Float_left Icon_close
OmniFaces 2.0 发布,JSF2 工具库
oschina 2014年11月26日

OmniFaces 2.0 发布,JSF2 工具库

oschina oschina 发布于2014年11月26日 收藏 4 评论 3

OmniFaces 2.0 发布,此版本最低要求:Java 1.6, JSF 2.0, EL 2.1 and Servlet 2.5 to Java 1.7, JSF 2.2, EL 2.2, Servlet 3.0 和 CDI 1.1。其中最重要的改进是要求可选 CDI 依赖,OmniFaces 2.0 不能在没有 CDI 的环境部署。

OmniFaces 2.0 完全向后兼容 JSF 2.1,但是不再支持 JSF 2.0;向后兼容 CDI 1.0,需要在不使用 Beans#destroy() 使用方法的时候至此和 CDI 1.1。请注意,在未来的 2.x 版本可能不会再兼容 CDI 1.0 和 JSF 2.1 版本。

更多内容请看发行说明

OmniFaces 2.0 JAR

OmniFaces 是一个 JSF 2 的工具库,其目的是为了让 JSF 应用开发更加简单。

如果你厌倦了重塑JSFUtil或FacesUtil实用程序类,为每个JSF web应用程序定制组件,使用 taghandlers 等来解决JSF的缺点的话,OmniFaces可能是你要找的东西!

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:OmniFaces 2.0 发布,JSF2 工具库
分享
评论(3)
最新评论
0
必须要求CDI,作死啊
0
前几天刚被这货坑了一次.......
0
Cool
顶部